summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-simulation/lincity
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-simulation/lincity')
-rw-r--r--games-simulation/lincity/Manifest1
-rw-r--r--games-simulation/lincity/lincity-1.13.1.ebuild52
-rw-r--r--games-simulation/lincity/metadata.xml8
3 files changed, 61 insertions, 0 deletions
diff --git a/games-simulation/lincity/Manifest b/games-simulation/lincity/Manifest
new file mode 100644
index 000000000000..361a1f67ff5c
--- /dev/null
+++ b/games-simulation/lincity/Manifest
@@ -0,0 +1 @@
+DIST lincity-1.13.1.tar.gz 1064236 SHA256 7b4cbd11ffd4cbed79a0aadb25f2b1c34e25a8201182fbb259ce2f450fe5015d SHA512 bc4ee7a1642b1efa25f9edaabd3aeb52d1ca1d016735c5094586f52fda3ec4e9080ff35fe518c1ccbfad9fd54babb370f4b9b6a158b4d2f43b7182155084eefc WHIRLPOOL b2065c73fda1f1ce3fc7803653a3ee9acadd58ad3d1f6b040cca7fe0c58df9d27d72894688b932013124ab0b866fc1fab68b94c25ab3fbf02c7f0b2a21d700c5
diff --git a/games-simulation/lincity/lincity-1.13.1.ebuild b/games-simulation/lincity/lincity-1.13.1.ebuild
new file mode 100644
index 000000000000..81e0bf2f1d3a
--- /dev/null
+++ b/games-simulation/lincity/lincity-1.13.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="city/country simulation game for X and Linux SVGALib"
+HOMEPAGE="http://lincity.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lincity/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="nls"
+
+# dep fix (bug #82318)
+RDEPEND="media-libs/libpng:0
+ x11-libs/libXext
+ x11-libs/libSM
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e '/^localedir/s:$(datadir):/usr/share:' \
+ po/Makefile.in.in \
+ intl/Makefile.in \
+ || die 'sed failed'
+}
+
+src_configure() {
+ egamesconf \
+ --with-gzip \
+ $(use_enable nls) \
+ --with-x
+}
+
+src_compile() {
+ # build system logic is severely broken
+ emake
+ emake X_PROGS
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc Acknowledgements CHANGES README* TODO
+ make_desktop_entry xlincity Lincity
+ dogamesbin xlincity
+ prepgamesdirs
+}
diff --git a/games-simulation/lincity/metadata.xml b/games-simulation/lincity/metadata.xml
new file mode 100644
index 000000000000..bb050ef9b982
--- /dev/null
+++ b/games-simulation/lincity/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">lincity</remote-id>
+ </upstream>
+</pkgmetadata>