summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-07-16 21:29:11 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-07-16 22:40:49 +0200
commitaaeee0dae978930005cf9a6c21b236f59e826f0e (patch)
treebdfddfe2c4f790ff17581517b8a26320110bf8c6 /games-simulation/openrct2
parentgames-simulation/openrct2: add missing deps for flac and vorbis (diff)
downloadgentoo-aaeee0dae978930005cf9a6c21b236f59e826f0e.tar.gz
gentoo-aaeee0dae978930005cf9a6c21b236f59e826f0e.tar.bz2
gentoo-aaeee0dae978930005cf9a6c21b236f59e826f0e.zip
games-simulation/openrct2: update live ebuild
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-simulation/openrct2')
-rw-r--r--games-simulation/openrct2/openrct2-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/games-simulation/openrct2/openrct2-9999.ebuild b/games-simulation/openrct2/openrct2-9999.ebuild
index 63415cb53ad0..45c46cdb7566 100644
--- a/games-simulation/openrct2/openrct2-9999.ebuild
+++ b/games-simulation/openrct2/openrct2-9999.ebuild
@@ -27,7 +27,7 @@ SRC_URI="
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="dedicated +lightfx +opengl scripting test +truetype"
+IUSE="dedicated +flac +lightfx +opengl scripting test +truetype +vorbis"
COMMON_DEPEND="
dev-libs/icu:=
@@ -39,7 +39,9 @@ COMMON_DEPEND="
!dedicated? (
media-libs/libsdl2
media-libs/speexdsp
+ flac? ( media-libs/flac )
opengl? ( virtual/opengl )
+ vorbis? ( media-libs/libvorbis )
)
dev-libs/openssl:0=
scripting? ( dev-lang/duktape:= )
@@ -105,6 +107,7 @@ src_configure() {
# as both packages do not exist in Gentoo, so support for them has been disabled.
local mycmakeargs=(
-DDISABLE_DISCORD_RPC=ON
+ $(usex !dedicated "-DDISABLE_FLAC=$(usex !flac)" "")
-DDISABLE_GOOGLE_BENCHMARK=ON
-DDISABLE_GUI=$(usex dedicated)
-DDISABLE_HTTP=OFF
@@ -112,6 +115,7 @@ src_configure() {
-DDISABLE_NETWORK=OFF
$(usex !dedicated "-DDISABLE_OPENGL=$(usex !opengl)" "")
-DDISABLE_TTF=$(usex !truetype)
+ $(usex !dedicated "-DDISABLE_VORBIS=$(usex !vorbis)" "")
-DDOWNLOAD_OBJECTS=OFF
-DDOWNLOAD_REPLAYS=OFF
-DDOWNLOAD_TITLE_SEQUENCES=OFF