summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-19 01:42:16 +0100
committerSam James <sam@gentoo.org>2021-08-19 01:42:16 +0100
commit1e9f3a4e1fdfc235dc42e4639a077bbb5595b338 (patch)
tree443e438b85734f1daf441517835ab7103f286e24 /games-simulation
parentgames-emulation/gnuboy: add missing patch (diff)
downloadgentoo-1e9f3a4e1fdfc235dc42e4639a077bbb5595b338.tar.gz
gentoo-1e9f3a4e1fdfc235dc42e4639a077bbb5595b338.tar.bz2
gentoo-1e9f3a4e1fdfc235dc42e4639a077bbb5595b338.zip
games-simulation/searchandrescue: add libsdl[joystick] dependency
Closes: https://bugs.gentoo.org/733522 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/searchandrescue/searchandrescue-1.7.0-r1.ebuild (renamed from games-simulation/searchandrescue/searchandrescue-1.7.0.ebuild)10
1 files changed, 5 insertions, 5 deletions
diff --git a/games-simulation/searchandrescue/searchandrescue-1.7.0.ebuild b/games-simulation/searchandrescue/searchandrescue-1.7.0-r1.ebuild
index a6949977970e..0d86fc160b73 100644
--- a/games-simulation/searchandrescue/searchandrescue-1.7.0.ebuild
+++ b/games-simulation/searchandrescue/searchandrescue-1.7.0-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit desktop flag-o-matic prefix toolchain-funcs xdg
MY_PN=SearchAndRescue
@@ -10,13 +11,14 @@ HOMEPAGE="http://searchandrescue.sourceforge.net/"
SRC_URI="mirror://sourceforge/searchandrescue/${MY_PN}-${PV}.tar.gz -> ${MY_PN}-${PV}.tar
mirror://sourceforge/searchandrescue/${MY_PN}-data-${PV}.tar.gz -> ${MY_PN}-data-${PV}.tar
mirror://sourceforge/searchandrescue/${MY_PN}-data-guadarrama-${PV}.tar.gz -> ${MY_PN}-data-guadarrama-${PV}.tar"
+S="${WORKDIR}"/${PN}_${PV}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
- media-libs/libsdl
+ media-libs/libsdl[joystick]
media-libs/sdl-mixer
virtual/glu
virtual/opengl
@@ -31,8 +33,6 @@ RDEPEND="
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-S=${WORKDIR}/${PN}_${PV}
-
src_unpack() {
unpack ${MY_PN}-${PV}.tar
mkdir data || die
@@ -52,7 +52,7 @@ src_prepare() {
}
src_configure() {
- export CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}" \
+ export CC="$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS}" \
CPP="$(tc-getCXX) ${LDFLAGS}"
append-flags -DNEW_GRAPHICS -DHAVE_SDL_MIXER