summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-03-31 16:26:59 +1000
committerMatt Jolly <kangie@gentoo.org>2024-04-01 13:48:17 +1000
commit2243dedc3478753e74f5c19b6208fa3d5dbd23cb (patch)
tree71e71377951b0a6fb3cf34c6cee0e02e592f4d0c /games-strategy/freeciv
parentgames-strategy/freeciv: add 3.1.0 (diff)
downloadgentoo-2243dedc3478753e74f5c19b6208fa3d5dbd23cb.tar.gz
gentoo-2243dedc3478753e74f5c19b6208fa3d5dbd23cb.tar.bz2
gentoo-2243dedc3478753e74f5c19b6208fa3d5dbd23cb.zip
games-strategy/freeciv: drop 3.0.10
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'games-strategy/freeciv')
-rw-r--r--games-strategy/freeciv/Manifest1
-rw-r--r--games-strategy/freeciv/freeciv-3.0.10.ebuild193
2 files changed, 0 insertions, 194 deletions
diff --git a/games-strategy/freeciv/Manifest b/games-strategy/freeciv/Manifest
index 432548adceb3..5ab062b74145 100644
--- a/games-strategy/freeciv/Manifest
+++ b/games-strategy/freeciv/Manifest
@@ -1,3 +1,2 @@
-DIST freeciv-3.0.10.tar.xz 43433812 BLAKE2B c529b2039e38070fef4758f4d316cfe952dcce4d4a773e70da22f2a3948f0506be493b4af20529d80749b47954bdd87a7aca8efb72c5502fefb2c103977f4e12 SHA512 4082e94deeda8d9b90f04137d6e7dfd39ff7232225a910f47519a464db553891e42289c1d7738f9ee0d9a16db143669bf8c4c5ce9492a4455ccd99906c956192
DIST freeciv-3.1.0.tar.gz 127748997 BLAKE2B 75b3d1341d8ab09af244f07f3df5b1817571c4958a4296f37f35a105fe5a8e3d2e8d2e0dc7eb1d1aaf3d4a4c6574ba75355595134dc5a255535bc14c604bb99f SHA512 514d796a54466790a5ce0f2abb6fd8cb9c124a2f19ab33d48ce7a7f0d8d92096b54352a5d3655da852cdbd807baf4969467e04b82f687347bdff92e09f7aad86
DIST freeciv-3.1.0_beta4.tar.gz 127725084 BLAKE2B f92c0aa75a47c165f808c761dc8e0a7cc76cafa722ef8d968ad69f379f2945774c811407f234df7ef22327c93dc2ec7b7765d0666bda249c573f57be3d03891a SHA512 b6864730583fe6dc17818813080132d6fa44c2adf8033a827b9a209f309c69e58bda41b8263a86006042a2e5f8bf99037e9d1d813a15ff1b9d48ec69b395f139
diff --git a/games-strategy/freeciv/freeciv-3.0.10.ebuild b/games-strategy/freeciv/freeciv-3.0.10.ebuild
deleted file mode 100644
index 624a5bb44ac6..000000000000
--- a/games-strategy/freeciv/freeciv-3.0.10.ebuild
+++ /dev/null
@@ -1,193 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-3 )
-
-inherit desktop lua-single qmake-utils xdg
-
-MY_PV="${PV/_beta/-beta}"
-MY_PV="${MY_PV/_rc/-RC}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="Multiplayer strategy game (Civilization Clone)"
-HOMEPAGE="https://www.freeciv.org/"
-
-if [[ ${PV} != *_beta* ]] && [[ ${PV} != *_rc* ]] ; then
- SRC_URI="mirror://sourceforge/freeciv/${MY_P}.tar.xz"
- KEYWORDS="~amd64 ~ppc64 ~x86"
-fi
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="aimodules auth dedicated +gtk mapimg modpack mysql nls qt5 readline sdl +server +sound sqlite +system-lua"
-
-REQUIRED_USE="
- system-lua? ( ${LUA_REQUIRED_USE} )
- dedicated? ( !gtk !mapimg !modpack !nls !qt5 !sdl !sound )
- !dedicated? ( || ( gtk qt5 sdl ) )
-"
-
-# postgres isn't yet really supported by upstream
-RDEPEND="
- app-arch/bzip2
- app-arch/xz-utils
- dev-libs/icu:=
- net-misc/curl
- sys-libs/zlib
- auth? (
- app-arch/zstd:=
- dev-libs/openssl:=
- !mysql? ( ( !sqlite? ( dev-db/mysql-connector-c:= ) ) )
- mysql? ( dev-db/mysql-connector-c:= )
- sqlite? ( dev-db/sqlite:3 )
- )
- aimodules? ( dev-libs/libltdl )
- !dedicated? (
- media-libs/libpng
- gtk? ( x11-libs/gtk+:3 )
- mapimg? ( media-gfx/imagemagick:= )
- modpack? ( x11-libs/gtk+:3 )
- nls? ( virtual/libintl )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- )
- !sdl? ( !gtk? ( x11-libs/gtk+:3 ) )
- sdl? (
- media-libs/libsdl2[video]
- media-libs/sdl2-gfx
- media-libs/sdl2-image[png]
- media-libs/sdl2-ttf
- )
- server? ( aimodules? ( dev-build/libtool ) )
- sound? (
- media-libs/libsdl2[sound]
- media-libs/sdl2-mixer[vorbis]
- )
- )
- readline? ( sys-libs/readline:= )
- system-lua? ( ${LUA_DEPS} )
-"
-DEPEND="${RDEPEND}
- !dedicated? ( x11-base/xorg-proto )
-"
-# Calls gzip during build
-BDEPEND="
- app-arch/gzip
- virtual/pkgconfig
- !dedicated? ( nls? ( sys-devel/gettext ) )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if ! use dedicated && ! use server ; then
- ewarn "Disabling server USE flag will make it impossible to start local"
- ewarn "games, but you will still be able to join multiplayer games."
- fi
-
- use system-lua && lua-single_pkg_setup
-}
-
-src_configure() {
- local myclient=() mydatabase=() myeconfargs=()
-
- if use auth ; then
- if ! use mysql && ! use sqlite ; then
- einfo "No database backend chosen, defaulting"
- einfo "to mysql!"
- mydatabase=( mysql )
- else
- use mysql && mydatabase+=( mysql )
- use sqlite && mydatabase+=( sqlite3 )
- fi
- else
- mydatabase=( no )
- fi
-
- if use dedicated ; then
- myclient=( no )
- myeconfargs+=(
- --enable-server
- --enable-freeciv-manual=html
- )
- else
- if use !sdl && use !gtk && ! use qt5 ; then
- einfo "No client backend given, defaulting to gtk3 client!"
- myclient=( gtk3 )
- else
- use sdl && myclient+=( sdl2 )
- # Since all gtk3 in gentoo is >= 3.22 we can use the better client
- use gtk && myclient+=( gtk3.22 )
- if use qt5 ; then
- local -x MOCCMD=$(qt5_get_bindir)/moc
- myclient+=( qt )
- fi
- fi
- myeconfargs+=(
- $(use_enable server)
- $(use_enable server freeciv-manual html )
- )
- fi
-
- myeconfargs+=(
- --enable-aimodules="$(usex aimodules "yes" "no")"
- --enable-client="${myclient[*]}"
- --enable-fcdb="${mydatabase[*]}"
- --enable-fcmp="$(usex modpack "gtk3" "no")"
- --enable-ipv6
- # disabling shared libs will break aimodules USE flag
- --enable-shared
- --localedir=/usr/share/locale
- --with-appdatadir="${EPREFIX}"/usr/share/metainfo
- $(use_enable mapimg)
- $(use_enable nls)
- $(use_enable sound sdl-mixer)
- $(use_enable system-lua sys-lua)
- $(use_with readline)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- if use server ; then
- # Create and install the html manual. It can't be done for dedicated
- # servers, because the 'freeciv-manual' tool is then not built. Also
- # delete freeciv-manual from the GAMES_BINDIR, because it's useless.
- # Note: to have it localized, it should be ran from _postinst, or
- # something like that, but then it's a PITA to avoid orphan files...
- # freeciv-manual only supports one ruleset argument at a time.
- elog "Generating html manual..."
- for RULESET in alien civ1 civ2 civ2civ3 classic experimental multiplayer sandbox
- do
- ./tools/freeciv-manual -r ${RULESET} || die
- docinto html/rulesets/${RULESET}
- dodoc ${RULESET}*.html
- done
- fi
-
- find "${ED}" -name "freeciv-manual*" -delete || die
-
- if use dedicated ; then
- elog "Tidying up dedicated server installation..."
- find "${ED}"/usr/share/man/man6/ \
- -not \( -name 'freeciv.6' -o -name 'freeciv-ruledit.6' \
- -o -name 'freeciv-ruleup.6' -o -name 'freeciv-server.6' \) -mindepth 1 -delete || die
- else
- # sdl client needs some special handling
- if use sdl ; then
- make_desktop_entry freeciv-sdl "Freeciv (SDL)" freeciv-client
- else
- rm "${ED}"/usr/share/man/man6/freeciv-sdl2.6 || die
- fi
-
- rm -f "${ED}"/usr/share/man/man6/freeciv-xaw.6 || die
- fi
-
- find "${ED}" -type f -name "*.la" -delete || die
-}