summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-19 05:23:34 +0100
committerSam James <sam@gentoo.org>2023-04-19 05:31:48 +0100
commit08d9399b00bdad8032b993ebeed3377304586091 (patch)
tree3e1f5712c91ec74159c8e297ce902afe66b3f424 /games-strategy
parentgames-strategy/colobot: fix build w/ gcc 13 (diff)
downloadgentoo-08d9399b00bdad8032b993ebeed3377304586091.tar.gz
gentoo-08d9399b00bdad8032b993ebeed3377304586091.tar.bz2
gentoo-08d9399b00bdad8032b993ebeed3377304586091.zip
games-strategy/colobot: drop -Werror
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/colobot/colobot-0.2.0_alpha.ebuild2
-rw-r--r--games-strategy/colobot/files/colobot-0.2.0_alpha-werror.patch20
2 files changed, 22 insertions, 0 deletions
diff --git a/games-strategy/colobot/colobot-0.2.0_alpha.ebuild b/games-strategy/colobot/colobot-0.2.0_alpha.ebuild
index ceef225ca257..f16813414298 100644
--- a/games-strategy/colobot/colobot-0.2.0_alpha.ebuild
+++ b/games-strategy/colobot/colobot-0.2.0_alpha.ebuild
@@ -43,6 +43,8 @@ PATCHES=(
"${FILESDIR}"/colobot-0.1.12-sndfile-link.patch
# https://github.com/colobot/colobot/pull/1576
"${FILESDIR}"/colobot-0.2.0_alpha-gcc13.patch
+ # No -Werror
+ "${FILESDIR}"/colobot-0.2.0_alpha-werror.patch
)
src_prepare() {
diff --git a/games-strategy/colobot/files/colobot-0.2.0_alpha-werror.patch b/games-strategy/colobot/files/colobot-0.2.0_alpha-werror.patch
new file mode 100644
index 000000000000..b326a0c0f7af
--- /dev/null
+++ b/games-strategy/colobot/files/colobot-0.2.0_alpha-werror.patch
@@ -0,0 +1,20 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -155,7 +155,7 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU")
+
+ message(STATUS "Detected GCC version 4.7+")
+
+- set(NORMAL_CXX_FLAGS "-std=gnu++11 -Wall -Werror -Wold-style-cast -pedantic-errors -Wmissing-declarations")
++ set(NORMAL_CXX_FLAGS "-std=gnu++11 -Wall -Wold-style-cast -pedantic-errors -Wmissing-declarations")
+ set(NORMAL_CXX_FLAGS "${NORMAL_CXX_FLAGS} -Wno-error=deprecated-declarations") # updated version of physfs is not available on some platforms so we keep using deprecated functions, see #958
+
+ if(NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 5.0)
+@@ -177,7 +177,7 @@ elseif(CMAKE_CXX_COMPILER_ID MATCHES "Clang")
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -fuse-ld=bfd")
+ endif()
+
+- set(NORMAL_CXX_FLAGS "-std=c++11 -Wall -Werror -Wold-style-cast -pedantic-errors -Wmissing-prototypes")
++ set(NORMAL_CXX_FLAGS "-std=c++11 -Wall -Wold-style-cast -pedantic-errors -Wmissing-prototypes")
+ set(NORMAL_CXX_FLAGS "${NORMAL_CXX_FLAGS} -Wno-error=deprecated-declarations") # updated version of physfs is not available on some platforms so we keep using deprecated functions, see #958
+ set(RELEASE_CXX_FLAGS "-O2")
+ set(DEBUG_CXX_FLAGS "-g -O0")