summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-04-05 12:54:09 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-04-05 12:54:37 -0400
commit24f8ed710a1919af52469a02baf97e4534a1880d (patch)
tree08b3087ef650c5c09dd6820f5fc3a9b9fffce4e6 /games-util/dfarc
parentprofiles: unmask >sys-kernel/linux-headers-3.16 on musl, bug #544476 (diff)
downloadgentoo-24f8ed710a1919af52469a02baf97e4534a1880d.tar.gz
gentoo-24f8ed710a1919af52469a02baf97e4534a1880d.tar.bz2
gentoo-24f8ed710a1919af52469a02baf97e4534a1880d.zip
games-util/dfarc: avoid trying to use windres (bug #579096)
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-util/dfarc')
-rw-r--r--games-util/dfarc/dfarc-3.12.ebuild8
-rw-r--r--games-util/dfarc/files/dfarc-3.12-nowindres.patch18
2 files changed, 24 insertions, 2 deletions
diff --git a/games-util/dfarc/dfarc-3.12.ebuild b/games-util/dfarc/dfarc-3.12.ebuild
index 492c684fbfa2..1d401e2ecc95 100644
--- a/games-util/dfarc/dfarc-3.12.ebuild
+++ b/games-util/dfarc/dfarc-3.12.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
WX_GTK_VER="3.0"
-inherit gnome2-utils fdo-mime wxwidgets games
+inherit eutils gnome2-utils fdo-mime wxwidgets games
DESCRIPTION="Frontend and .dmod installer for GNU FreeDink"
HOMEPAGE="http://www.freedink.org/"
@@ -22,6 +22,10 @@ RDEPEND="
DEPEND="${RDEPEND}
nls? ( >=dev-util/intltool-0.31 )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nowindres.patch
+}
+
src_configure() {
egamesconf \
$(use_enable nls) \
diff --git a/games-util/dfarc/files/dfarc-3.12-nowindres.patch b/games-util/dfarc/files/dfarc-3.12-nowindres.patch
new file mode 100644
index 000000000000..78b71096973c
--- /dev/null
+++ b/games-util/dfarc/files/dfarc-3.12-nowindres.patch
@@ -0,0 +1,18 @@
+--- src/Makefile.in.orig 2016-04-05 12:49:17.997412757 -0400
++++ src/Makefile.in 2016-04-05 12:50:42.058496766 -0400
+@@ -100,7 +100,6 @@
+ Package.$(OBJEXT) RecursiveDelete.$(OBJEXT) Tar.$(OBJEXT) \
+ DFArcFrame_Base.$(OBJEXT) Options_Base.$(OBJEXT) \
+ Package_Base.$(OBJEXT) InstallVerifyFrame_Base.$(OBJEXT)
+-@HAVE_WINDRES_TRUE@nodist_dfarc_OBJECTS = woeres.$(OBJEXT)
+ dfarc_OBJECTS = $(am_dfarc_OBJECTS) $(nodist_dfarc_OBJECTS)
+ dfarc_LDADD = $(LDADD)
+ AM_V_P = $(am__v_P_@AM_V@)
+@@ -346,7 +345,6 @@
+ InstallVerifyFrame_Base.wxg dink.ico
+
+ # How do we handle resources embedded in the executable binary?
+-@HAVE_WINDRES_TRUE@nodist_dfarc_SOURCES = woeres.rc
+ all: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) all-am
+