summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-16 00:17:18 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-16 00:43:32 +0200
commitbee29934057335599f42c66401309844cb0a3266 (patch)
tree39f7d21c5bd4fa618d926a50a95cf069500a70ae /gnome-base/gnome-light
parentgnome-base/gnome-core-apps: version bump 3.22.2 → 3.24.0 (diff)
downloadgentoo-bee29934057335599f42c66401309844cb0a3266.tar.gz
gentoo-bee29934057335599f42c66401309844cb0a3266.tar.bz2
gentoo-bee29934057335599f42c66401309844cb0a3266.zip
gnome-base/gnome-light: version bump 3.22.2 → 3.24.0
Package-Manager: Portage-2.3.7, Repoman-2.3.3 RepoMan-Options: --force
Diffstat (limited to 'gnome-base/gnome-light')
-rw-r--r--gnome-base/gnome-light/gnome-light-3.24.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnome-base/gnome-light/gnome-light-3.24.0.ebuild b/gnome-base/gnome-light/gnome-light-3.24.0.ebuild
new file mode 100644
index 000000000000..180917e5daf0
--- /dev/null
+++ b/gnome-base/gnome-light/gnome-light-3.24.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator
+
+P_RELEASE="$(get_version_components 2)"
+
+DESCRIPTION="Meta package for GNOME-Light, merge this package to install"
+HOMEPAGE="https://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="2.0"
+IUSE="cups +gnome-shell"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~amd64 ~ia64 ~x86"
+
+# XXX: Note to developers:
+# This is a wrapper for the 'light' GNOME 3 desktop, and should only consist of
+# the bare minimum of libs/apps needed. It is basically gnome-base/gnome without
+# any apps, but shouldn't be used by users unless they know what they are doing.
+RDEPEND="!gnome-base/gnome
+ >=gnome-base/gnome-core-libs-${PV}[cups?]
+
+ >=gnome-base/gnome-session-${PV}
+ >=gnome-base/gnome-settings-daemon-${PV}[cups?]
+ >=gnome-base/gnome-control-center-${PV}[cups?]
+
+ >=gnome-base/nautilus-${PV}
+
+ gnome-shell? (
+ >=x11-wm/mutter-${PV}
+ >=gnome-base/gnome-shell-${PV} )
+
+ >=x11-themes/adwaita-icon-theme-${P_RELEASE}
+ >=x11-themes/gnome-themes-standard-3.22.3
+ >=x11-themes/gnome-backgrounds-${P_RELEASE}
+
+ >=x11-terms/gnome-terminal-${PV}
+"
+DEPEND=""
+PDEPEND=">=gnome-base/gvfs-1.32"
+S="${WORKDIR}"
+
+pkg_pretend() {
+ if ! use gnome-shell; then
+ # Users probably want to use e16, sawfish, etc
+ ewarn "You're not installing GNOME Shell"
+ ewarn "You will have to install and manage a window manager by yourself"
+ fi
+}
+
+pkg_postinst() {
+ # Remember people where to find our project information
+ elog "Please remember to look at https://wiki.gentoo.org/wiki/Project:GNOME"
+ elog "for information about the project and documentation."
+}