summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-24 21:40:31 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-24 21:48:47 -0400
commitd1657ef078ab7a2b5b303c38f3dd165b1b2e70ce (patch)
tree5899eb4dcf0fc3cb56444e9b7a90aad13275263d /gnome-base/gsettings-desktop-schemas
parentprofiles/arch/alpha: make openntpd mask more generic (diff)
downloadgentoo-d1657ef078ab7a2b5b303c38f3dd165b1b2e70ce.tar.gz
gentoo-d1657ef078ab7a2b5b303c38f3dd165b1b2e70ce.tar.bz2
gentoo-d1657ef078ab7a2b5b303c38f3dd165b1b2e70ce.zip
gnome-base/gsettings-desktop-schemas: Version bump to 43.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base/gsettings-desktop-schemas')
-rw-r--r--gnome-base/gsettings-desktop-schemas/Manifest1
-rw-r--r--gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-43.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/gnome-base/gsettings-desktop-schemas/Manifest b/gnome-base/gsettings-desktop-schemas/Manifest
index 02f8f32ae618..7f7c19867640 100644
--- a/gnome-base/gsettings-desktop-schemas/Manifest
+++ b/gnome-base/gsettings-desktop-schemas/Manifest
@@ -1 +1,2 @@
DIST gsettings-desktop-schemas-42.0.tar.xz 709372 BLAKE2B abe682b32dc3c419a65b3752b9fa6821ed0058f06a4b123728a8d095ff3b6f65b569d9b80d43aac28fa5d79439c316cb628f0c63cd500c7ebc40cc4eff704bdb SHA512 db73988a6b38857d1aa6588ccac42099c57dcc187ef01776567cc7c28aff67dc06d6a8a067e0c69167d03cd865f0c1d58e75469a40f969084bb2537b088f8664
+DIST gsettings-desktop-schemas-43.0.tar.xz 736456 BLAKE2B 8fa0866a2747af370dbdc329afc2272e998d992bb4d19079a15d8f04063bd09660cabaf19123fedced5c6ebca13a21c207e1238178344d92a3a3d60ef0aa0152 SHA512 a3acd953ec206375e99e0988438e46b42668094d1b5425ccf21a7fe451887b705e2a5efe6870ee6bfc6722f54e5aa6a422de2af2099f29a5230f415744df2cf8
diff --git a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-43.0.ebuild b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-43.0.ebuild
new file mode 100644
index 000000000000..42509dcaeef9
--- /dev/null
+++ b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-43.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="Collection of GSettings schemas for GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
+
+BDEPEND="
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ # Revert change to 'Source Code Pro 10' and 'Cantarell 11' fonts back to generic sans and monospace aliases
+ "${FILESDIR}"/3.32.0-default-fonts.patch
+)
+
+src_prepare() {
+ default
+
+ python_fix_shebang build-aux/meson/post-install.py
+}
+
+src_configure() {
+ meson_src_configure $(meson_use introspection)
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}