summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-base/libbonobo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-base/libbonobo')
-rw-r--r--gnome-base/libbonobo/Manifest1
-rw-r--r--gnome-base/libbonobo/libbonobo-2.24.3-r1.ebuild66
-rw-r--r--gnome-base/libbonobo/metadata.xml5
3 files changed, 72 insertions, 0 deletions
diff --git a/gnome-base/libbonobo/Manifest b/gnome-base/libbonobo/Manifest
new file mode 100644
index 000000000000..be791df92f7c
--- /dev/null
+++ b/gnome-base/libbonobo/Manifest
@@ -0,0 +1 @@
+DIST libbonobo-2.24.3.tar.bz2 1354929 SHA256 5310957fa90691689c0557218b8833f681666cae160bd84e1f2c2705189a4ebe SHA512 c97224ba2d4afc07e520399aa04849487a4ec4dd1b80b56e0472b4c3ebbddd0ce0105ba63ca2f823590788754791127dbe86b49cb39239db0019f8104db25716 WHIRLPOOL f6a2195d6dd2b79038621cca85037c8f490d6b900b180104e922745ebbb6ae23cbc2e7c52b67b14868ded7b0942284d85c60a5caf56a4ee4ac2ea20efc9ac977
diff --git a/gnome-base/libbonobo/libbonobo-2.24.3-r1.ebuild b/gnome-base/libbonobo/libbonobo-2.24.3-r1.ebuild
new file mode 100644
index 000000000000..a17a7ee48b6c
--- /dev/null
+++ b/gnome-base/libbonobo/libbonobo-2.24.3-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome2
+
+DESCRIPTION="GNOME CORBA framework"
+HOMEPAGE="http://developer.gnome.org/libbonobo/stable/"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="debug examples test"
+
+RDEPEND="
+ >=dev-libs/glib-2.14:2
+ >=gnome-base/orbit-2.14.0
+ >=dev-libs/libxml2-2.4.20:2
+ >=sys-apps/dbus-1.0.0
+ >=dev-libs/dbus-glib-0.74
+ >=dev-libs/popt-1.5
+ !gnome-base/bonobo-activation
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/yacc
+ sys-devel/flex
+ x11-apps/xrdb
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35
+"
+
+# Tests are broken in several ways as reported in bug #288689 and upstream
+# doesn't take care since libbonobo is deprecated.
+RESTRICT="test"
+
+src_prepare() {
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die
+
+ if ! use test; then
+ # don't waste time building tests, bug #226223
+ sed 's/tests//' -i Makefile.am Makefile.in || die
+ fi
+
+ if ! use examples; then
+ sed 's/samples//' -i Makefile.am Makefile.in || die
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure $(use_enable debug bonobo-activation-debug)
+}
+
+src_test() {
+ # Pass tests with FEATURES userpriv, see bug #288689
+ unset ORBIT_SOCKETDIR
+ emake check
+}
diff --git a/gnome-base/libbonobo/metadata.xml b/gnome-base/libbonobo/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/gnome-base/libbonobo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>