summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/nm-applet/nm-applet-0.9.8.10-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/nm-applet/nm-applet-0.9.8.10-r1.ebuild')
-rw-r--r--gnome-extra/nm-applet/nm-applet-0.9.8.10-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnome-extra/nm-applet/nm-applet-0.9.8.10-r1.ebuild b/gnome-extra/nm-applet/nm-applet-0.9.8.10-r1.ebuild
new file mode 100644
index 000000000000..a78f4793e674
--- /dev/null
+++ b/gnome-extra/nm-applet/nm-applet-0.9.8.10-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+GNOME_ORG_MODULE="network-manager-applet"
+
+inherit eutils gnome2
+
+DESCRIPTION="GNOME applet for NetworkManager"
+HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="bluetooth gconf +introspection modemmanager"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+RDEPEND="
+ app-crypt/libsecret
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/dbus-glib-0.88
+ >=sys-apps/dbus-1.4.1
+ >=sys-auth/polkit-0.96-r1
+ >=x11-libs/gtk+-3:3[introspection?]
+ >=x11-libs/libnotify-0.7.0
+
+ app-text/iso-codes
+ >=net-misc/networkmanager-0.9.8[introspection?]
+ net-misc/mobile-broadband-provider-info
+
+ bluetooth? ( >=net-wireless/gnome-bluetooth-2.27.6:= )
+ gconf? (
+ >=gnome-base/gconf-2.20:2
+ gnome-base/libgnome-keyring )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+ modemmanager? ( >=net-misc/modemmanager-0.7.990 )
+ virtual/freedesktop-icon-theme
+ virtual/notification-daemon
+ virtual/libgudev:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --with-gtkver=3 \
+ --disable-more-warnings \
+ --disable-static \
+ --localstatedir=/var \
+ $(use_with bluetooth) \
+ $(use_enable gconf migration) \
+ $(use_enable introspection) \
+ $(use_with modemmanager modem-manager-1)
+}