summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-15 23:33:31 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-15 23:38:55 -0400
commit5a98d5e6fb736c338b3b1139293f09b66420cd09 (patch)
tree88bbac66893c31d671f6cf44e1856b6ecc12ca45 /gnome-extra
parentgnome-extra/gnome-getting-started-docs: Version bump to 3.38.1 (diff)
downloadgentoo-5a98d5e6fb736c338b3b1139293f09b66420cd09.tar.gz
gentoo-5a98d5e6fb736c338b3b1139293f09b66420cd09.tar.bz2
gentoo-5a98d5e6fb736c338b3b1139293f09b66420cd09.zip
gnome-extra/gnome-tweaks: Version bump to 40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-tweaks/Manifest1
-rw-r--r--gnome-extra/gnome-tweaks/gnome-tweaks-40.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/gnome-extra/gnome-tweaks/Manifest b/gnome-extra/gnome-tweaks/Manifest
index 098765e98953..4af9eea366bd 100644
--- a/gnome-extra/gnome-tweaks/Manifest
+++ b/gnome-extra/gnome-tweaks/Manifest
@@ -1 +1,2 @@
DIST gnome-tweaks-3.34.1.tar.xz 247980 BLAKE2B 55fbb16bcdb1a9ea4b5ca84df802266e07347377eab3712284973146fcc0797af59df5985725b1a95a1fba0d26b580a1c9862675978876de5eeb0de9c0060be3 SHA512 c922bf696b9ff48c8c39fd4ae06f4b72ea7b18645ad41552b0367859066d7601bc59521643335931e1cce799344a1c1ac9a7c28408de4c19bfa4127594a2ec7d
+DIST gnome-tweaks-40.0.tar.xz 251908 BLAKE2B 4280e7565da3f95d7bcd81ba874d2f15e8c3834ab052cb4cf7cde8060eaea016670acf6f441d2cbce4b7566ba0bb7a7f9666b257893bc7b22b1cdc4d5a0edee2 SHA512 c3467f40af6bb79c2b10cb429e93aa29261066c2a5fd744bf2801c4e596cc270d45302ebfa942ee0c40067849c12e1ccd404c40e7f594bcff4c44cfe3f90bb97
diff --git a/gnome-extra/gnome-tweaks/gnome-tweaks-40.0.ebuild b/gnome-extra/gnome-tweaks/gnome-tweaks-40.0.ebuild
new file mode 100644
index 000000000000..127de63566b9
--- /dev/null
+++ b/gnome-extra/gnome-tweaks/gnome-tweaks-40.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit gnome.org meson python-single-r1 xdg
+
+DESCRIPTION="Customize advanced GNOME 3 options"
+HOMEPAGE="https://wiki.gnome.org/Apps/Tweaks"
+
+LICENSE="GPL-3+ CC0-1.0"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="${PYTHON_DEPS}"
+# See README.md for list of deps
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.10.2:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=gnome-base/gnome-settings-daemon-3
+ x11-themes/sound-theme-freedesktop
+
+ >=dev-libs/glib-2.58:2
+ >=x11-libs/gtk+-3.12:3[introspection]
+ >=gnome-base/gnome-desktop-3.30:3[introspection]
+ gui-libs/libhandy:0.0[introspection]
+ net-libs/libsoup:2.4[introspection]
+ x11-libs/libnotify[introspection]
+
+ >=gnome-base/gsettings-desktop-schemas-3.33.0
+ >=gnome-base/gnome-shell-3.24
+ x11-wm/mutter
+"
+BDEPEND=">=sys-devel/gettext-0.19.8"
+
+PATCHES=(
+ "${FILESDIR}"/3.28.1-gentoo-cursor-themes.patch # Add contents of Gentoo's cursor theme directory to cursor theme list
+)
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}"/usr/bin/
+}