summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-26 18:24:58 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-27 13:26:54 +0300
commit186206b99e05965440ec229f67c94aa19175ae15 (patch)
tree0ed802cdc35a450746647c03855d52aa4a56e968 /gui-apps
parentkde-plasma/plasma-meta: Keyword 6.1.1 arm64, #934215 (diff)
downloadgentoo-186206b99e05965440ec229f67c94aa19175ae15.tar.gz
gentoo-186206b99e05965440ec229f67c94aa19175ae15.tar.bz2
gentoo-186206b99e05965440ec229f67c94aa19175ae15.zip
gui-apps/waypipe: add 0.9.1
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37313 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/waypipe/Manifest1
-rw-r--r--gui-apps/waypipe/waypipe-0.9.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/gui-apps/waypipe/Manifest b/gui-apps/waypipe/Manifest
index e526a228f598..85a41ab5ac81 100644
--- a/gui-apps/waypipe/Manifest
+++ b/gui-apps/waypipe/Manifest
@@ -1 +1,2 @@
DIST waypipe-v0.9.0.tar.bz2 193493 BLAKE2B 891b1015951459faf15c181c35499558458fd69c63695f4b6be67e686c8ba7806f0193ed0fc4500b370345b570536b6fdbb3c01f2fe861e87e00b1d4db7c05d7 SHA512 c37b630f4659ccc52d2a85a749971d552d5d535fc33e30aea1c2d22b057aaf3cf2756d6347cc89e3068ce59a14e871e7ffae9016608803549d0e7b1b6a0bd1cf
+DIST waypipe-v0.9.1.tar.bz2 193469 BLAKE2B adffa29092eae327e6e07f5b20c136121018f3da6de01fcef8cde49a4bca3da8c5785db4e3e9e825bee49779fe9274fb357ac25b93fc632ce5ede53ebe74f9db SHA512 bd9899e2e8adba453861022c1e95ad41a5979d72cbbd1a346949450fb8da5450aa240bdd555a5774ed9e360f07bbf52bc10bb5e46ff579535033fe2ccc600511
diff --git a/gui-apps/waypipe/waypipe-0.9.1.ebuild b/gui-apps/waypipe/waypipe-0.9.1.ebuild
new file mode 100644
index 000000000000..844cedd732dc
--- /dev/null
+++ b/gui-apps/waypipe/waypipe-0.9.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit meson python-any-r1
+
+DESCRIPTION="Transparent network proxy for Wayland compositors"
+HOMEPAGE="https://gitlab.freedesktop.org/mstoeckl/waypipe"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mstoeckl/waypipe"
+else
+ SRC_URI="https://gitlab.freedesktop.org/mstoeckl/waypipe/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ S="${WORKDIR}"/${PN}-v${PV}
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+WAYPIPE_FLAG_MAP_X86=( avx2:with_avx2 avx512f:with_avx512f sse3:with_sse3 )
+WAYPIPE_FLAG_MAP_ARM=( neon:with_neon_opts )
+WAYPIPE_FLAG_MAP=(
+ "${WAYPIPE_FLAG_MAP_X86[@]/#/cpu_flags_x86_}"
+ "${WAYPIPE_FLAG_MAP_ARM[@]/#/cpu_flags_arm_}"
+)
+
+IUSE="dmabuf ffmpeg lz4 systemtap test vaapi zstd ${WAYPIPE_FLAG_MAP[@]%:*}"
+REQUIRED_USE="vaapi? ( ffmpeg )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dmabuf? (
+ media-libs/mesa[gbm(+),vaapi?,wayland]
+ x11-libs/libdrm
+ )
+ lz4? ( app-arch/lz4 )
+ systemtap? ( dev-debug/systemtap )
+ vaapi? ( media-libs/libva[drm(+),wayland] )
+ ffmpeg? (
+ media-video/ffmpeg[x264,vaapi?]
+ )
+ zstd? ( app-arch/zstd )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/scdoc
+ virtual/pkgconfig
+ test? ( dev-libs/weston[examples,headless,remoting,screen-sharing,wayland-compositor] )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ $(meson_use systemtap with_systemtap)
+ $(meson_feature dmabuf with_dmabuf)
+ $(meson_feature ffmpeg with_video)
+ $(meson_feature lz4 with_lz4)
+ $(meson_feature vaapi with_vaapi)
+ $(meson_feature zstd with_zstd)
+ )
+ local fl
+ for fl in "${WAYPIPE_FLAG_MAP[@]}"; do
+ emesonargs+=( $(meson_use "${fl%:*}" "${fl#*:}") )
+ done
+ meson_src_configure
+}