summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-10-17 12:12:49 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-10-17 12:13:04 -0500
commit56e4aba72d7affab20659ff294fd46a1c3443537 (patch)
treed559eae2aa6ab3fcf6c58eadd92dcfa89f5fb53f /gui-apps
parentgui-apps/swayidle: add riscv flag to other versions (diff)
downloadgentoo-56e4aba72d7affab20659ff294fd46a1c3443537.tar.gz
gentoo-56e4aba72d7affab20659ff294fd46a1c3443537.tar.bz2
gentoo-56e4aba72d7affab20659ff294fd46a1c3443537.zip
gui-apps/swayidle: 1.6 cleanup
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/swayidle/Manifest1
-rw-r--r--gui-apps/swayidle/swayidle-1.6.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/gui-apps/swayidle/Manifest b/gui-apps/swayidle/Manifest
index 03b5e047ea60..b90665dfcb80 100644
--- a/gui-apps/swayidle/Manifest
+++ b/gui-apps/swayidle/Manifest
@@ -1,2 +1 @@
-DIST swayidle-1.6.tar.gz 10131 BLAKE2B c0391d288c780c61b72b7a5ac612efc18c359cc7d622faa308e22b1e4359c064bc2824e7cb8fc14143ddde54fc6980bdc5d449d1f16a867b54aef9dfbaa4ff17 SHA512 c82b0d2aee06f87fd71e9e2208e917c0dc7afe80ab0b782c3165127519445021d8cf363292eee99f939165eb813909f2a4ee74153e776557c6d06672de2c1c82
DIST swayidle-1.7.tar.gz 12458 BLAKE2B 06462d286e4786173d26241056c2b0c71a9253eac31e0b33bd70c5729ff172c3b8ab2c6377c3bc4a6f53cf580adbaac792d90f46da7f944bcc5a4055b642fe5a SHA512 26a48c510caaadb1ad694426e82880ab1547b7b0ef8ac62a2c2ee41c7b8cc0554f4925b0abdc6dc37f2501a171c0b6ae53c56b045b5c545093f3b0463aefcf24
diff --git a/gui-apps/swayidle/swayidle-1.6.ebuild b/gui-apps/swayidle/swayidle-1.6.ebuild
deleted file mode 100644
index 94194af2e4ae..000000000000
--- a/gui-apps/swayidle/swayidle-1.6.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="Idle management daemon for Wayland"
-HOMEPAGE="https://github.com/swaywm/swayidle"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
-else
- SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="elogind +man systemd"
-REQUIRED_USE="?? ( elogind systemd )"
-
-DEPEND="
- dev-libs/wayland
- elogind? ( >=sys-auth/elogind-237[policykit] )
- systemd? ( >=sys-apps/systemd-237[policykit] )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- >=dev-libs/wayland-protocols-1.14
- virtual/pkgconfig
- man? ( app-text/scdoc )
-"
-
-src_configure() {
- local emesonargs=(
- -Dman-pages=$(usex man enabled disabled)
- "-Dfish-completions=true"
- "-Dzsh-completions=true"
- "-Dbash-completions=true"
- "-Dwerror=false"
- )
-
- if use systemd; then
- emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
- elif use elogind; then
- emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
- else
- emesonargs+=("-Dlogind=disabled")
- fi
-
- meson_src_configure
-}