summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-15 22:21:46 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-15 22:40:34 -0400
commit09e9261d51a8a00e4a37d8c1956930f50be2335b (patch)
tree085fd37964e9a5d2eb8c681e0af5dee14a52e974 /gui-libs/libhandy
parentgames-puzzle/gnome-sudoku: Version bump to 43.0 (diff)
downloadgentoo-09e9261d51a8a00e4a37d8c1956930f50be2335b.tar.gz
gentoo-09e9261d51a8a00e4a37d8c1956930f50be2335b.tar.bz2
gentoo-09e9261d51a8a00e4a37d8c1956930f50be2335b.zip
gui-libs/libhandy: Version bump to 1.8.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs/libhandy')
-rw-r--r--gui-libs/libhandy/Manifest1
-rw-r--r--gui-libs/libhandy/libhandy-1.8.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/gui-libs/libhandy/Manifest b/gui-libs/libhandy/Manifest
index 2490c745795b..f59e7c186c88 100644
--- a/gui-libs/libhandy/Manifest
+++ b/gui-libs/libhandy/Manifest
@@ -1 +1,2 @@
DIST libhandy-1.6.3.tar.xz 1785692 BLAKE2B e48c8724a5298d61412562f4be00e7c3198dae896d143319adc3c84296f0ce1272a46b23e432df02f184a330c342ed6c34bc072fdcc648cbf1923aa17105b3bf SHA512 bf210bc49b512fe74438759e2b8238fbba9c8ccd57e96b7a72f484df080a407da56ffcacbef3265da8de6a1edc954d4b3d77eaddbd1f62141d41db5c17253b49
+DIST libhandy-1.8.0.tar.xz 1796032 BLAKE2B 15929cfde5e01b25e0ccc4dfa94bb0d12272b02a5c5196fcb3a85a898bf8384faa4101114e14f44d53f326fa5321254bba85e3c7f41e426ebd116e2d3dfd96ca SHA512 88f37d310ddc26a26612648d9f7beff6e77347a2cf59f682690dc838c3ec1bad9408ed39571c6cd779bea3d334a9c275ba3789d45c11c0a3e454617d41cc0035
diff --git a/gui-libs/libhandy/libhandy-1.8.0.ebuild b/gui-libs/libhandy/libhandy-1.8.0.ebuild
new file mode 100644
index 000000000000..5837b57a1218
--- /dev/null
+++ b/gui-libs/libhandy/libhandy-1.8.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg vala virtualx
+
+DESCRIPTION="Building blocks for modern adaptive GNOME apps"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libhandy/"
+
+LICENSE="LGPL-2.1+"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="examples glade gtk-doc +introspection test +vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.24.1:3[introspection?]
+ glade? ( dev-util/glade:3.10= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1
+ app-text/docbook-xml-dtd:4.3 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofiling=false # -pg passing
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ $(meson_use examples)
+ $(meson_feature glade glade_catalog)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}