summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2023-11-09 21:28:58 +0200
committerJimi Huotari <chiitoo@gentoo.org>2023-11-09 23:45:35 +0200
commitf32f35aa5e13dde5d0d3e7b8a006787e0ac86948 (patch)
tree38483cbb99f19539b28ea36adc582ac4a3169fe3 /gui-libs
parentmedia-gfx/lximage-qt: add 1.4.0 (diff)
downloadgentoo-f32f35aa5e13dde5d0d3e7b8a006787e0ac86948.tar.gz
gentoo-f32f35aa5e13dde5d0d3e7b8a006787e0ac86948.tar.bz2
gentoo-f32f35aa5e13dde5d0d3e7b8a006787e0ac86948.zip
gui-libs/xdg-desktop-portal-lxqt: add 0.5.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/xdg-desktop-portal-lxqt/Manifest1
-rw-r--r--gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.5.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/gui-libs/xdg-desktop-portal-lxqt/Manifest b/gui-libs/xdg-desktop-portal-lxqt/Manifest
index d7df162dd4b3..ace2bcdb6a30 100644
--- a/gui-libs/xdg-desktop-portal-lxqt/Manifest
+++ b/gui-libs/xdg-desktop-portal-lxqt/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-lxqt-0.4.0.tar.xz 16024 BLAKE2B 2f362f9ddff42d68dfe69bcebd229566fe396a5a14d9ee9f1650706a34a98f31291a9901ef7121a976c679481192959d785ca8c8401bf8b2839dd18e42eee6bc SHA512 9295da6dc9370e01a48729848d9d19c9afea980335fb1cefeb91abf34b12d53579d876ccc952e2ef1440e10f0937b9c4a02d2c8473c9cad812da0388bfcacbe1
+DIST xdg-desktop-portal-lxqt-0.5.0.tar.xz 16044 BLAKE2B f4b872038c58eebe3c565f55d29e24f9b247d2a18fd60981df9546a7fab422aa9ae1f6e94608a99a091cda4bda1e5ce878fa4d997a457f7c2014191fd631a0d2 SHA512 3f1a0de1fcc577b14b69c98b715f627dc636edc8663786374627196873a6e123aab2b6051bd86416729eb6e101ec0625051716b981a3fc4d7b5c7ddcd46ceae8
diff --git a/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.5.0.ebuild b/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.5.0.ebuild
new file mode 100644
index 000000000000..5ee331073c73
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using Qt/KF5/libfm-qt"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.13.0"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/kwindowsystem:5
+ >=x11-libs/libfm-qt-1.4:=
+"
+RDEPEND="${DEPEND}
+ sys-apps/xdg-desktop-portal
+"