summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-08-10 12:37:11 -0700
committerYixun Lan <dlan@gentoo.org>2024-08-11 02:41:36 +0000
commit1fada7643d26e1f684a213cac654b7f56c0e88ed (patch)
tree6775ed6c844bc0605dc859043fe4f9b20b90d2ad /gui-wm
parentgui-wm/hyprland: sync live (diff)
downloadgentoo-1fada7643d26e1f684a213cac654b7f56c0e88ed.tar.gz
gentoo-1fada7643d26e1f684a213cac654b7f56c0e88ed.tar.bz2
gentoo-1fada7643d26e1f684a213cac654b7f56c0e88ed.zip
gui-wm/hyprland: fix generateVersion.sh error
Closes: https://bugs.gentoo.org/937601 Co-authored-by: xz-dev <xiangzhedev@gmail.com> Signed-off-by: xz-dev <xiangzhedev@gmail.com> Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/hyprland/hyprland-0.42.0-r1.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/gui-wm/hyprland/hyprland-0.42.0-r1.ebuild b/gui-wm/hyprland/hyprland-0.42.0-r1.ebuild
index 5595a6c47d3c..1328a9a6c961 100644
--- a/gui-wm/hyprland/hyprland-0.42.0-r1.ebuild
+++ b/gui-wm/hyprland/hyprland-0.42.0-r1.ebuild
@@ -82,6 +82,12 @@ pkg_setup() {
fi
}
+src_prepare() {
+ # skip version.h
+ sed -i -e "s|scripts/generateVersion.sh|echo|g" meson.build || die
+ default
+}
+
src_configure() {
local emesonargs=(
$(meson_feature legacy-renderer legacy_renderer)