summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-12-20 21:19:01 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-12-21 23:32:18 +1100
commit16ab492853978178f8bce5605ecc7c3842b1b2a6 (patch)
tree01147bd12e23243803643a48f1de80bc47c778ea /kde-apps/knotes
parentkde-apps/kmail: Drop old (diff)
downloadgentoo-16ab492853978178f8bce5605ecc7c3842b1b2a6.tar.gz
gentoo-16ab492853978178f8bce5605ecc7c3842b1b2a6.tar.bz2
gentoo-16ab492853978178f8bce5605ecc7c3842b1b2a6.zip
kde-apps/knotes: Add missing RDEPEND
Needs kde-apps/kdepim-runtime for akonadi resources Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-apps/knotes')
-rw-r--r--kde-apps/knotes/knotes-16.12.0-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/kde-apps/knotes/knotes-16.12.0-r1.ebuild b/kde-apps/knotes/knotes-16.12.0-r1.ebuild
new file mode 100644
index 000000000000..d504035c543c
--- /dev/null
+++ b/kde-apps/knotes/knotes-16.12.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Note taking application"
+HOMEPAGE="https://www.kde.org/"
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kdnssd)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep akonadi-search)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep kontactinterface)
+ $(add_kdeapps_dep libkdepim)
+ $(add_kdeapps_dep pimcommon)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ $(add_qt_dep qtxml)
+ dev-libs/grantlee:5
+ dev-libs/libxslt
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kdepim-runtime)
+"
+
+src_configure() {
+# local mycmakeargs=(
+# # FIXME: Does not build (last checked 2016-02-17)
+# $(cmake-utils_use_find_package X Qt5X11Extras)
+# $(cmake-utils_use_find_package X X11)
+# )
+
+ kde5_src_configure
+}