summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-08 19:04:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-08 19:04:39 +0100
commitd7443e05892e21953f2476002a87f3c0213706bb (patch)
treebdc943e4106bc2c6f20218650cf96563b88f1827 /kde-apps/thumbnailers
parentsys-fs/zfs: drop old (diff)
downloadgentoo-d7443e05892e21953f2476002a87f3c0213706bb.tar.gz
gentoo-d7443e05892e21953f2476002a87f3c0213706bb.tar.bz2
gentoo-d7443e05892e21953f2476002a87f3c0213706bb.zip
kde-apps: Add KDE Applications 17.12.3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'kde-apps/thumbnailers')
-rw-r--r--kde-apps/thumbnailers/Manifest1
-rw-r--r--kde-apps/thumbnailers/thumbnailers-17.12.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/kde-apps/thumbnailers/Manifest b/kde-apps/thumbnailers/Manifest
index 61002245ae05..aa11ba1f383a 100644
--- a/kde-apps/thumbnailers/Manifest
+++ b/kde-apps/thumbnailers/Manifest
@@ -1,2 +1,3 @@
DIST kdegraphics-thumbnailers-17.08.3.tar.xz 41488 BLAKE2B 415204552ee63ca69d656d36b30daceaa53519c72cc923eede2dc77be12008d8338198d46a3a2da15e02790c72890321878e194c597daf8194a58229647f9b2f SHA512 25c533cfbf0e515fb8167143c724e877e4ed7a2100a1c0625cd53b10969a9127ae0b1f9e1a42abd076258525737a3862e7cc11bc31401551d9cdc5473c188485
DIST kdegraphics-thumbnailers-17.12.2.tar.xz 41616 BLAKE2B 3a5c4f4b9120bf34e0b79ad2995a82f976f3d53256c5348b724e9233140c4a053fcdb9c686c892170d79ccac8d04324279700535991372695c436f631293502c SHA512 0fdf3222fd833a5bb1290906885fc1d576207db0d80e9e7c9a561ed1453db6d783c4e0001f0437f618423f99678ba81d974ab8cef1e5aad5e03ab6f1b8e4fa62
+DIST kdegraphics-thumbnailers-17.12.3.tar.xz 41628 BLAKE2B 41a95cf201d03d7ef0a4b35c9603c61113f3fbf2a5319724b88a14de979c310e2d50f2ac0fa68d60cdb7bf4d396d21d59bb60622b18ad548cd5389b68e8c0e46 SHA512 67bfea3314008d2024d07afe02b4a9b2d7d952460e831c152b6eb79b9214e73c4a90312b27f6fb02666edf2e40baa59c5c924f5750bb56d731ab09c9b2cddd6c
diff --git a/kde-apps/thumbnailers/thumbnailers-17.12.3.ebuild b/kde-apps/thumbnailers/thumbnailers-17.12.3.ebuild
new file mode 100644
index 000000000000..ff1362dbc75b
--- /dev/null
+++ b/kde-apps/thumbnailers/thumbnailers-17.12.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_BLOCK_SLOT4=false
+KMNAME="kdegraphics-thumbnailers"
+inherit kde5
+
+DESCRIPTION="Thumbnail generators for PDF/PS and RAW files"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="raw"
+
+DEPEND="
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtgui)
+ raw? (
+ $(add_kdeapps_dep libkdcraw)
+ $(add_kdeapps_dep libkexiv2)
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package raw KF5KExiv2)
+ $(cmake-utils_use_find_package raw KF5KDcraw)
+ )
+
+ kde5_src_configure
+}