summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-09 13:03:36 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-09 13:04:07 +0100
commit6546627244d8e80cafc37b9d8cfc2f2d50a9bd60 (patch)
treea25235ee5210c09b9fdaa195d75cadb4e5cab5a4 /kde-apps
parentgnome-base/librsvg: Remove old (diff)
downloadgentoo-6546627244d8e80cafc37b9d8cfc2f2d50a9bd60.tar.gz
gentoo-6546627244d8e80cafc37b9d8cfc2f2d50a9bd60.tar.bz2
gentoo-6546627244d8e80cafc37b9d8cfc2f2d50a9bd60.zip
kde-apps/pykde4: Fix build w/ dev-python/sip-4.19
Gentoo-bug: 604284 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/pykde4/Manifest1
-rw-r--r--kde-apps/pykde4/pykde4-4.14.3-r1.ebuild6
-rw-r--r--kde-apps/pykde4/pykde4-4.14.3-r2.ebuild171
3 files changed, 175 insertions, 3 deletions
diff --git a/kde-apps/pykde4/Manifest b/kde-apps/pykde4/Manifest
index 95faafe1cca4..220ae005708f 100644
--- a/kde-apps/pykde4/Manifest
+++ b/kde-apps/pykde4/Manifest
@@ -1 +1,2 @@
+DIST pykde4-4.14.3-sip419.patch.bz2 3089 SHA256 458a92483f85462a302b5563b2c0d2fcdcd2c5f6d6a1e9b259fc7b87d3bedd66 SHA512 7355f662abdb9981731fc4e0f475fae37ba4887f91493d2d2b69685e2dbfe0a4873d9bf75c53039f1870432a9410d691d888f8c6b7161b2e3e7d92dd37664c76 WHIRLPOOL 2643adf09214916225f726d90ac6f9e4db02618c10011a2bdd6230f9baeb4016736e962e7649e3c29bbc52bb14282aa531545f7b5e1d779660efbf11f9a2c9c3
DIST pykde4-4.14.3.tar.xz 2006504 SHA256 7fb9d7b5ed03d531243ebd67939baf30933452dafbdfca866e6653e9a77d80fc SHA512 42430f83bf41dc5d7511369250ff480fd7b90954b4ace8dbda2d6151ee3f3c979fe3d9b0163cda76df52107e982d4ac518fa1c28bc1d711d97f2d8739eaff1f3 WHIRLPOOL 5df847617a220ef9e1330f3c970bb6f785e713ebbed8a04ef4a3c9d1470d1b4a2032177f59df4d4baf89a0975b8c02f63f133747588cb65a3fa5d849e51b4d4d
diff --git a/kde-apps/pykde4/pykde4-4.14.3-r1.ebuild b/kde-apps/pykde4/pykde4-4.14.3-r1.ebuild
index a09a44d68e85..164b695f36c8 100644
--- a/kde-apps/pykde4/pykde4-4.14.3-r1.ebuild
+++ b/kde-apps/pykde4/pykde4-4.14.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -20,8 +20,8 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
- >=dev-python/PyQt4-4.11.1[${PYTHON_USEDEP},dbus,declarative,script,sql,svg,webkit,X]
- >=dev-python/sip-4.16.2:=[${PYTHON_USEDEP}]
+ <dev-python/PyQt4-4.12[${PYTHON_USEDEP},dbus,declarative,script,sql,svg,webkit,X]
+ <dev-python/sip-4.19:=[${PYTHON_USEDEP}]
kde-frameworks/kdelibs:4[opengl]
akonadi? ( $(add_kdeapps_dep kdepimlibs) )
"
diff --git a/kde-apps/pykde4/pykde4-4.14.3-r2.ebuild b/kde-apps/pykde4/pykde4-4.14.3-r2.ebuild
new file mode 100644
index 000000000000..893b55007da7
--- /dev/null
+++ b/kde-apps/pykde4/pykde4-4.14.3-r2.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE="threads"
+OPENGL_REQUIRED="always"
+CMAKE_MAKEFILE_GENERATOR="emake"
+WEBKIT_REQUIRED="always"
+inherit python-r1 portability kde4-base multilib eutils
+
+DESCRIPTION="Python bindings for KDE SC 4"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi debug doc examples test"
+HOMEPAGE="https://techbase.kde.org/Development/Languages/Python"
+
+SRC_URI+=" https://dev.gentoo.org/~johu/distfiles/${P}-sip419.patch.bz2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/PyQt4-4.12[${PYTHON_USEDEP},dbus,declarative,script,sql,svg,webkit,X]
+ >=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
+ kde-frameworks/kdelibs:4[opengl]
+ akonadi? ( $(add_kdeapps_dep kdepimlibs) )
+"
+DEPEND="${RDEPEND}
+ dev-lang/python-exec:2[${PYTHON_USEDEP}]
+ sys-devel/libtool
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc-5.patch"
+ "${DISTDIR}/${P}-sip419.patch.bz2"
+)
+
+pkg_setup() {
+ kde4-base_pkg_setup
+
+ have_python2=false
+
+ scan_python_versions() {
+ if [[ ${EPYTHON} == python2.* ]]; then
+ have_python2=true
+ fi
+ }
+ python_foreach_impl scan_python_versions
+
+ if ! ${have_python2}; then
+ ewarn "You do not have a Python 2 version selected."
+ ewarn "kpythonpluginfactory will not be built"
+ fi
+}
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if ! use examples; then
+ sed -e '/^ADD_SUBDIRECTORY(examples)/s/^/# DISABLED /' -i CMakeLists.txt \
+ || die "Failed to disable examples"
+ fi
+
+ # See bug 322351
+ use arm && epatch "${FILESDIR}/${PN}-4.14.0-arm-sip.patch"
+
+ sed -e 's/kpythonpluginfactory /kpython${PYTHON_SHORT_VERSION}pluginfactory /g' \
+ -i kpythonpluginfactory/CMakeLists.txt || die
+
+ if ${have_python2}; then
+ mkdir -p "${WORKDIR}/wrapper" || die "failed to copy wrapper"
+ cp "${FILESDIR}/kpythonpluginfactorywrapper.c-r2" "${WORKDIR}/wrapper/kpythonpluginfactorywrapper.c" || die "failed to copy wrapper"
+ fi
+ python_copy_sources
+
+}
+
+src_configure() {
+ configuration() {
+ local mycmakeargs=(
+ -DWITH_PolkitQt=OFF
+ -DWITH_QScintilla=OFF
+ -DPYKDEUIC4_ALTINSTALL=TRUE
+ -DWITH_Nepomuk=OFF
+ -DWITH_Soprano=OFF
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ -DPYTHON_EXECUTABLE=${PYTHON}
+ )
+ local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
+ kde4-base_src_configure
+ }
+
+ python_foreach_impl run_in_build_dir configuration
+}
+
+echo_and_run() {
+ echo "$@"
+ "$@"
+}
+
+src_compile() {
+ compilation() {
+ local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
+ kde4-base_src_compile
+ }
+ python_foreach_impl run_in_build_dir compilation
+
+ if ${have_python2}; then
+ pushd "${WORKDIR}/wrapper" > /dev/null
+ echo_and_run libtool --tag=CC --mode=compile $(tc-getCC) \
+ -shared \
+ ${CFLAGS} ${CPPFLAGS} \
+ -DEPREFIX="\"${EPREFIX}\"" \
+ -DPLUGIN_DIR="\"/usr/$(get_libdir)/kde4\"" -c \
+ -o kpythonpluginfactorywrapper.lo \
+ kpythonpluginfactorywrapper.c
+ echo_and_run libtool --tag=CC --mode=link $(tc-getCC) \
+ -shared -module -avoid-version \
+ ${CFLAGS} ${LDFLAGS} \
+ -o kpythonpluginfactory.la \
+ -rpath "${EPREFIX}/usr/$(get_libdir)/kde4" \
+ kpythonpluginfactorywrapper.lo \
+ $(dlopen_lib)
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir kde4-base_src_test
+}
+
+src_install() {
+ installation() {
+ emake DESTDIR="${D}" install
+
+ mkdir -p "${D%/}$(python_get_scriptdir)" || die
+ mv "${ED%/}/usr/bin/pykdeuic4-${EPYTHON/python/}" \
+ "${D%/}$(python_get_scriptdir)"/pykdeuic4 || die
+
+ python_fix_shebang "${D%/}$(python_get_scriptdir)"/pykdeuic4
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+
+ dosym ../lib/python-exec/python-exec2 /usr/bin/pykdeuic4
+
+ # As we don't call the eclass's src_install, we have to install the docs manually
+ DOCS=("${S}"/{AUTHORS,NEWS,README})
+ use doc && HTML_DOCS=("${S}/docs/html/")
+ einstalldocs
+
+ if ${have_python2}; then
+ pushd "${WORKDIR}/wrapper" > /dev/null
+ echo_and_run libtool --mode=install install kpythonpluginfactory.la "${ED}/usr/$(get_libdir)/kde4/kpythonpluginfactory.la"
+ rm "${ED}/usr/$(get_libdir)/kde4/kpythonpluginfactory.la"
+ popd > /dev/null
+ fi
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if use examples; then
+ echo
+ elog "PyKDE4 examples have been installed to"
+ elog "${EPREFIX}/usr/share/apps/${PN}/examples"
+ echo
+ fi
+}