summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-14 13:46:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-14 13:46:10 +0200
commit82d39affe7c0394f58b7dbda11a4df2d233e86d1 (patch)
tree0c87d649221962703f877bfcae356c45a4d72b6c /kde-frameworks/kauth
parentkde-apps/kde-dev-utils: Fix build with KF-5.48 (diff)
downloadgentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.tar.gz
gentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.tar.bz2
gentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.zip
kde-frameworks: Add KDE Frameworks 5.48
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.48.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index 6e9c0ae616e6..b8c68ab9a337 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1,2 +1,3 @@
DIST kauth-5.46.0.tar.xz 84932 BLAKE2B 10a3e1f612f2569894236da4fd7bd8f02259dd9258364dcdde7685691e49789805d3ba8fffd662779cc64a74881bc2ef5907173416d876fb8a321eb903a7139b SHA512 dd94d8923ea7caa1f420d4a906876e1082c1afc97130731f579e6c3e9b377ec9c1abfa1d489ed60c11fff248da455d87a8cde8a581156d61bf6410b8c19d3401
DIST kauth-5.47.0.tar.xz 84932 BLAKE2B ba726fa3f318305d7897d6aecf5c9518b9eb9f1131055605924e3a61782c4846806fa8f9facc05b402fad9abada101ec7918b782255f286cae29ee9fc1a45592 SHA512 91ec2de4b54c70988f0040bd8c27a35fa5a53e6f28a1c842c59aa5816d677ff5dbf9b250a5a16facf6a2e034c96cdf4db52ecec2f0b7641a66535abc1a258e24
+DIST kauth-5.48.0.tar.xz 84920 BLAKE2B a2a800a5bf0c3cfe9c32b4b7b668c8905618a322faefbdce6c56071a40ef4321a913aef2ce034092aabe2769423b69acf874be1582bc5f2f768f4a1e78830145 SHA512 34023dc452ebc0297c2a866b848109d4e34dcd4afccc541e76d98f07b2817b9928bc4ab100eded4f326aa6fa18f6c76cef6723fcd09cd8b56649b7175c1812bb
diff --git a/kde-frameworks/kauth/kauth-5.48.0.ebuild b/kde-frameworks/kauth/kauth-5.48.0.ebuild
new file mode 100644
index 000000000000..ee6570cb1d6b
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.48.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls +policykit"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ policykit? ( sys-auth/polkit-qt[qt5(+)] )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt5-1)
+ )
+
+ kde5_src_configure
+}