summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-29 00:38:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-29 14:46:09 +0200
commit017d20b8f56c2cc9279558f3363d35816fd5c7d3 (patch)
tree8649cebbb26f37704d30110d4a75bc502e5388eb /kde-frameworks/kio
parentkde-frameworks/plasma: Drop 5.74.0 (r0) (diff)
downloadgentoo-017d20b8f56c2cc9279558f3363d35816fd5c7d3.tar.gz
gentoo-017d20b8f56c2cc9279558f3363d35816fd5c7d3.tar.bz2
gentoo-017d20b8f56c2cc9279558f3363d35816fd5c7d3.zip
kde-frameworks/kio: kio_trash: remove too strict permission check
Fixes an upstream Gentoo user report from 2004. Upstream commit 03bcb3d3ff89074a68839b6ebeb8030ef0ee4fd1 KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=76380 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kio')
-rw-r--r--kde-frameworks/kio/files/kio-5.74.1-kio_trash-too-strict-perms-check.patch67
-rw-r--r--kde-frameworks/kio/kio-5.74.1-r1.ebuild96
2 files changed, 163 insertions, 0 deletions
diff --git a/kde-frameworks/kio/files/kio-5.74.1-kio_trash-too-strict-perms-check.patch b/kde-frameworks/kio/files/kio-5.74.1-kio_trash-too-strict-perms-check.patch
new file mode 100644
index 000000000000..d0b0ca0769cc
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.74.1-kio_trash-too-strict-perms-check.patch
@@ -0,0 +1,67 @@
+From 03bcb3d3ff89074a68839b6ebeb8030ef0ee4fd1 Mon Sep 17 00:00:00 2001
+From: David Faure <faure@kde.org>
+Date: Fri, 11 Sep 2020 11:54:09 +0200
+Subject: [PATCH] kio_trash: remove unnecessarily strict permission check
+
+Tested with `chmod 0770 /d/.Trash-1000` (where /d is a mount point),
+kio_trash complained about security checks before this commit,
+and works with it.
+
+Also tested with a USB key which ends up mounted as
+type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=100,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2). After kio_trash creates .Trash-1000
+it complained about a "strange filesystem", and while this is still true :),
+the removal of the code in TrashImpl::initTrashDirectory makes
+the trash dir on the USB key usable.
+
+BUG: 76380
+FIXED-IN: 5.74
+---
+ src/ioslaves/trash/trashimpl.cpp | 25 ++++---------------------
+ 1 file changed, 4 insertions(+), 21 deletions(-)
+
+diff --git a/src/ioslaves/trash/trashimpl.cpp b/src/ioslaves/trash/trashimpl.cpp
+index b1ba87a4..9ec7cc7a 100644
+--- a/src/ioslaves/trash/trashimpl.cpp
++++ b/src/ioslaves/trash/trashimpl.cpp
+@@ -1210,9 +1210,9 @@ QString TrashImpl::trashForMountPoint(const QString &topdir, bool createIfNeeded
+ const QByteArray trashDir_c = QFile::encodeName(trashDir);
+ if (QT_LSTAT(trashDir_c.constData(), &buff) == 0) {
+ if ((buff.st_uid == uid) // must be owned by user
+- && (S_ISDIR(buff.st_mode)) // must be a dir
+- && (!S_ISLNK(buff.st_mode)) // not a symlink
+- && ((buff.st_mode & 0777) == 0700)) { // rwx for user, ------ for group and others
++ && S_ISDIR(buff.st_mode) // must be a dir
++ && !S_ISLNK(buff.st_mode) // not a symlink
++ && ((buff.st_mode & 0700) == 0700)) { // and we need write access to it
+
+ if (checkTrashSubdirs(trashDir_c)) {
+ return trashDir;
+@@ -1248,24 +1248,7 @@ bool TrashImpl::initTrashDirectory(const QByteArray &trashDir_c) const
+ return false;
+ }
+ //qCDebug(KIO_TRASH);
+- // This trash dir will be useable only if the directory is owned by user.
+- // In theory this is the case, but not on e.g. USB keys...
+- uid_t uid = getuid();
+- QT_STATBUF buff;
+- if (QT_LSTAT(trashDir_c.constData(), &buff) != 0) {
+- return false; // huh?
+- }
+- if ((buff.st_uid == uid) // must be owned by user
+- && ((buff.st_mode & 0777) == 0700)) { // rwx for user, --- for group and others
+-
+- return checkTrashSubdirs(trashDir_c);
+-
+- } else {
+- qCWarning(KIO_TRASH) << trashDir_c << "just created, by it doesn't have the right permissions, probably some strange unsupported filesystem";
+- ::rmdir(trashDir_c.constData());
+- return false;
+- }
+- return true;
++ return checkTrashSubdirs(trashDir_c);
+ }
+
+ bool TrashImpl::checkTrashSubdirs(const QByteArray &trashDir_c) const
+--
+GitLab
+
diff --git a/kde-frameworks/kio/kio-5.74.1-r1.ebuild b/kde-frameworks/kio/kio-5.74.1-r1.ebuild
new file mode 100644
index 000000000000..8ba617db566c
--- /dev/null
+++ b/kde-frameworks/kio/kio-5.74.1-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org xdg-utils
+
+DESCRIPTION="Framework providing transparent file and data management"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="acl +handbook kerberos +kwallet X"
+
+# drop qtnetwork subslot operator when QT_MINIMAL >= 5.15.0
+RDEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5=[ssl]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/kauth-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kbookmarks-${PVCUT}*:5
+ =kde-frameworks/kcodecs-${PVCUT}*:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kcrash-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kjobwidgets-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/ktextwidgets-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ =kde-frameworks/solid-${PVCUT}*:5
+ acl? (
+ sys-apps/attr
+ virtual/acl
+ )
+ handbook? ( =kde-frameworks/kdoctools-${PVCUT}*:5 )
+ kerberos? ( virtual/krb5 )
+ kwallet? ( =kde-frameworks/kwallet-${PVCUT}*:5 )
+ X? ( >=dev-qt/qtx11extras-${QTMIN}:5 )
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ test? ( sys-libs/zlib )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libX11
+ x11-libs/libXrender
+ )
+"
+PDEPEND="
+ >=kde-frameworks/kded-${PVCUT}:5
+"
+
+# tests hang
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}"/${P}-kio_trash-too-strict-perms-check.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package acl ACL)
+ $(cmake_use_find_package handbook KF5DocTools)
+ $(cmake_use_find_package kerberos GSSAPI)
+ $(cmake_use_find_package kwallet KF5Wallet)
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ ecm_pkg_postrm
+ xdg_desktop_database_update
+}