summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-10 20:45:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-10 20:45:26 +0100
commitd945698d38bd79ea0737872b8507f506341f1d2b (patch)
tree743e8fff1ddf64fa2c0cf57bf2fdf312ae258931 /kde-frameworks/knotifyconfig
parentnet-misc/openssh: Remove accidental debug code in 7.9_p1 (diff)
downloadgentoo-d945698d38bd79ea0737872b8507f506341f1d2b.tar.gz
gentoo-d945698d38bd79ea0737872b8507f506341f1d2b.tar.bz2
gentoo-d945698d38bd79ea0737872b8507f506341f1d2b.zip
kde-frameworks/knotifyconfig: Fix build with USE -phonon
Closes: https://bugs.gentoo.org/672866 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/knotifyconfig')
-rw-r--r--kde-frameworks/knotifyconfig/files/knotifyconfig-5.53.0-phonon-optional.patch48
-rw-r--r--kde-frameworks/knotifyconfig/knotifyconfig-5.53.0.ebuild2
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-frameworks/knotifyconfig/files/knotifyconfig-5.53.0-phonon-optional.patch b/kde-frameworks/knotifyconfig/files/knotifyconfig-5.53.0-phonon-optional.patch
new file mode 100644
index 000000000000..0854b76da840
--- /dev/null
+++ b/kde-frameworks/knotifyconfig/files/knotifyconfig-5.53.0-phonon-optional.patch
@@ -0,0 +1,48 @@
+From 78a1dcc794f57be993ada7c6f129586ebb6b181e Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Mon, 10 Dec 2018 16:15:08 +0100
+Subject: Fix build without Phonon
+
+Summary:
+f6d55baf5aa88eaab6b2f96c025064f081d13cea replaced ${PHONON_LIBS} with
+Phonon's imported target. This breaks in the case when Phonon isn't
+found or disabled via -DCMAKE_DISABLE_FIND_PACKAGES_Phonon4Qt5=TRUE
+because the imported target isn't known. It worked previously because
+${PHONON_LIBS} was just empty when Phonon wasn't available.
+
+Test Plan:
+Building without phonon works now and and it still builds
+with phonon available and successfully links to it.
+
+Subscribers: kde-frameworks-devel
+
+Tags: #frameworks
+
+Differential Revision: https://phabricator.kde.org/D17479
+---
+ src/CMakeLists.txt | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 3dd0039..b93cabc 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -27,9 +27,15 @@ target_link_libraries(KF5NotifyConfig
+ PRIVATE
+ KF5::I18n
+ KF5::KIOWidgets # KUrlRequester
+- Phonon::phonon4qt5
+ Qt5::DBus)
+
++if(HAVE_PHONON)
++ target_link_libraries(KF5NotifyConfig
++ PRIVATE
++ Phonon::phonon4qt5
++ )
++endif()
++
+ set_target_properties(KF5NotifyConfig PROPERTIES
+ VERSION ${KNOTIFYCONFIG_VERSION_STRING}
+ SOVERSION ${KNOTIFYCONFIG_SOVERSION}
+--
+cgit v1.1
diff --git a/kde-frameworks/knotifyconfig/knotifyconfig-5.53.0.ebuild b/kde-frameworks/knotifyconfig/knotifyconfig-5.53.0.ebuild
index 7c834ad4baff..65aca3a9a07b 100644
--- a/kde-frameworks/knotifyconfig/knotifyconfig-5.53.0.ebuild
+++ b/kde-frameworks/knotifyconfig/knotifyconfig-5.53.0.ebuild
@@ -22,3 +22,5 @@ RDEPEND="
phonon? ( media-libs/phonon[qt5(+)] )
"
DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-phonon-optional.patch" )