summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-04-08 17:32:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-04-08 17:33:41 +0200
commit772d5a9a522abd8a460b5be807bf568635a9abf0 (patch)
treeecf9649a57c723b7b09a2921555ba446a029701b /kde-frameworks/kwindowsystem/kwindowsystem-5.33.0.ebuild
parentmedia-gfx/gimp: Sync 9999, move to https (diff)
downloadgentoo-772d5a9a522abd8a460b5be807bf568635a9abf0.tar.gz
gentoo-772d5a9a522abd8a460b5be807bf568635a9abf0.tar.bz2
gentoo-772d5a9a522abd8a460b5be807bf568635a9abf0.zip
kde-frameworks: Add KDE Frameworks 5.33.0 release
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-frameworks/kwindowsystem/kwindowsystem-5.33.0.ebuild')
-rw-r--r--kde-frameworks/kwindowsystem/kwindowsystem-5.33.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-frameworks/kwindowsystem/kwindowsystem-5.33.0.ebuild b/kde-frameworks/kwindowsystem/kwindowsystem-5.33.0.ebuild
new file mode 100644
index 000000000000..e487d4f75b73
--- /dev/null
+++ b/kde-frameworks/kwindowsystem/kwindowsystem-5.33.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing access to properties and features of the window manager"
+LICENSE="|| ( LGPL-2.1 LGPL-3 ) MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls X"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+ X? ( x11-proto/xproto )
+"
+
+RESTRICT+=" test"
+
+DOCS=( "docs/README.kstartupinfo" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}