summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-14 00:36:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-14 08:51:25 +0200
commit9efd24de6c1fdb4a027b91db473262aba16731e0 (patch)
tree2b546c79713a9915fb32d1fd0542ba5c5354ed81 /kde-frameworks/purpose
parentprofiles: mask ruby 2.4 for removal (diff)
downloadgentoo-9efd24de6c1fdb4a027b91db473262aba16731e0.tar.gz
gentoo-9efd24de6c1fdb4a027b91db473262aba16731e0.tar.bz2
gentoo-9efd24de6c1fdb4a027b91db473262aba16731e0.zip
kde-frameworks: Add KDE Frameworks 5.71.0
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.71.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 9fa92c722621..17e4c2c175f2 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1 +1,2 @@
DIST purpose-5.70.0.tar.xz 153468 BLAKE2B e918c824658b52829607ba9ddf727178d2689aa64f5caa075dbf0947ca53819f6b8a15d49df1d3c4a408a7017cfc63416a46af2466ca51e16c7383c45b799060 SHA512 932fc3a56c47a3a031f4acc32ae5ea04733c99f953ce3248e60bc47b836d26929e71bb10633c3859d642c8667e4b1dbb60f03f450da8b0c2bda703142cf80916
+DIST purpose-5.71.0.tar.xz 155344 BLAKE2B 8d62e6335f177035920dc727614cf028b04b43d5528d62544239b835c3a684b28ea55e1d88b6d466918b9c63a31a1becdcabada8a86f3b8f201bce1e93ef5176 SHA512 594e3de6d3a083189eadb2c7ae704fbcbe5296d63a0e173abe044dbda932115422886c50ce9154d279789c2c136f5779b8d891d7591831200c42b2f766db29e8
diff --git a/kde-frameworks/purpose/purpose-5.71.0.ebuild b/kde-frameworks/purpose/purpose-5.71.0.ebuild
new file mode 100644
index 000000000000..27625e1f89a5
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.71.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.1
+inherit ecm kde.org
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="+dolphin +kaccounts"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ dolphin? ( =kde-frameworks/knotifications-${PVCUT}*:5 )
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+# requires running environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package dolphin KF5Notifications)
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst(){
+ ecm_pkg_postinst
+
+ if ! has_version "kde-misc/kdeconnect[app]" ; then
+ elog "Optional runtime dependency:"
+ elog "kde-misc/kdeconnect[app] (send through KDE Connect)"
+ fi
+}