summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-06-14 08:42:13 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-06-14 10:25:02 +0200
commitc1cbcfae4f072ea840d15bbbac032d1e615a74ba (patch)
tree23266989848bd60d1a388f394feca8204c19d74c /kde-frameworks
parentkde-frameworks/solid: 5.83.0 version bump (diff)
downloadgentoo-c1cbcfae4f072ea840d15bbbac032d1e615a74ba.tar.gz
gentoo-c1cbcfae4f072ea840d15bbbac032d1e615a74ba.tar.bz2
gentoo-c1cbcfae4f072ea840d15bbbac032d1e615a74ba.zip
kde-frameworks/sonnet: 5.83.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.83.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index 3c6caadf6d38..3e095fed30de 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1 +1,2 @@
DIST sonnet-5.82.0.tar.xz 293844 BLAKE2B 6e2c4558957d845a281955c63de7dd87fc21634a4cb3e89af47345da070b1dc15e91c558a865e0c7ac5e2adb2454d36b6b8f2f521112b4fd07ad1b2ad02f6c04 SHA512 3bc876b1e06ba5c08c05ce74530a2584b9853e8c9742f66b19529e7f78f3aad89d3a72e0a615e912d1cfd7a24b3de3a9068d0f72dce3c51ca03b896eeedde817
+DIST sonnet-5.83.0.tar.xz 295076 BLAKE2B e5f78f873251eb9fc431196cb6a176376f1f69add3bf66b67aa56bf61026d937c017e1a7f14fa9ede921f965d4cec9c7d74f9420e7b831638725c1a2670d4a5c SHA512 6e5c2ec0b736675b4ba79297613d9229b4f26f1bede2d4a9acb1334a3df0e006c2c4b9ac516989fcd37c516d8afe822c655fd995cbd9e06d26cc1e97538e4b67
diff --git a/kde-frameworks/sonnet/sonnet-5.83.0.ebuild b/kde-frameworks/sonnet/sonnet-5.83.0.ebuild
new file mode 100644
index 000000000000..c2df24e9d697
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.83.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package aspell ASPELL)
+ $(cmake_use_find_package hunspell HUNSPELL)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # sonnet-test_settings: bug 680032
+ # sonnet-test_autodetect: bug 779994
+ local myctestargs=(
+ -E "(sonnet-test_autodetect|sonnet-test_settings|sonnet-test_highlighter)"
+ )
+
+ ecm_src_test
+}