summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-21 22:03:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-23 15:48:42 +0200
commit1f64c80838899482f5fb927789bb3a02b5ec5863 (patch)
tree8a25e307449ee77ec6f068cfe1a3009c34d34c1a /kde-plasma/ksshaskpass
parentdev-java/java-config: clean up bogus version for eprefix folks. (diff)
downloadgentoo-1f64c80838899482f5fb927789bb3a02b5ec5863.tar.gz
gentoo-1f64c80838899482f5fb927789bb3a02b5ec5863.tar.bz2
gentoo-1f64c80838899482f5fb927789bb3a02b5ec5863.zip
kde-plasma: Add KDE Plasma 5.19.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.19.2.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 16600adc9bb8..3bc2338439af 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.18.5.tar.xz 22148 BLAKE2B 31521b28a840bfbb14cdef2484dde8908a0ffbeda5d54663243bd93a070d77d72019b5436f0a4f838e7c8b9f60992b06636e181b6ced51d17a13ba4f7c3918b6 SHA512 8cf75491c04537cdbab11613dc0f9317631c282e4f371664164dc0936d08f744a39777b696b772e05b06ef1257d42f7ae29abfbbd022e661073fdf880fe63fcf
DIST ksshaskpass-5.19.1.tar.xz 23528 BLAKE2B a8ba394330116e81a40def8b340fbc687a0cc09ba75467f629761e95185698ec456c36cecc74c901cf0738ca88acf4a76dfc26fcb0a46ae4ddcc87d3b8e01822 SHA512 c507d5110114a0961eadefc91e931ed54ef463995c277a2618e92238c6c4d606f7325c748a69485385dd89bf29d4d17a34053c2b58ccf2dadf8f2c0e27e6bba6
+DIST ksshaskpass-5.19.2.tar.xz 23484 BLAKE2B 3ca4507fb0efe8b82b21939fc5c77dd1b670394d1de710843d1c24e1882ef271eed5bcae58c75ab46a4f2985a35eed1f10fe493714f6cfb2e6addaf82048be43 SHA512 0a2d22313777dcedf1c267f6627ec452226df156b290e758fe224a91fe608efdcf6881c754979fe47e35028eeb0ab24a54ed223a9653e87c82c0018c63e9a1de
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.19.2.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.19.2.ebuild
new file mode 100644
index 000000000000..49efe670a3c0
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.19.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.71.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ ecm_pkg_setup
+
+ local srcfile=/etc/plasma/startup/05-ksshaskpass.sh
+ local newfile=/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh
+ if [[ -f "${EROOT}"${srcfile} ]]; then
+ local md5=$(md5sum "${EROOT}"${srcfile})
+ if [[ ${md5%% *} != 615ae8f5b0090ff7f51d0edee7885d55 ]]; then
+ elog "Existing modified "${EPREFIX}"${srcfile} detected."
+ elog "Copying to "${EPREFIX}"${newfile}..."
+ cp -v "${EROOT}"${srcfile} "${T}"/ || die
+ fi
+ fi
+}
+
+src_prepare() {
+ ecm_src_prepare
+ if [[ ! -f "${T}"/05-ksshaskpass.sh ]]; then
+ cp "${FILESDIR}"/05-ksshaskpass.sh "${T}"/ || die
+ fi
+}
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 script
+ if [[ -e "${EROOT}"/etc/plasma/startup/05-ksshaskpass.sh ]]; then
+ rm "${EROOT}"/etc/plasma/startup/05-ksshaskpass.sh || die
+ elog "Removed obsolete ${EPREFIX}/etc/plasma/startup/05-ksshaskpass.sh"
+ fi
+}