summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-04-26 00:32:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-04-26 00:32:44 +0200
commit4d494e2e1529fa104a7cf51aaaef9e0fb2b7876c (patch)
tree316872de7f52d5b42e24612dd98f09364d0c3c96 /kde-plasma/plasma-integration
parentdev-lang/python: Forward-port the distutils -OO patch to 3.6, #616594 (diff)
downloadgentoo-4d494e2e1529fa104a7cf51aaaef9e0fb2b7876c.tar.gz
gentoo-4d494e2e1529fa104a7cf51aaaef9e0fb2b7876c.tar.bz2
gentoo-4d494e2e1529fa104a7cf51aaaef9e0fb2b7876c.zip
kde-plasma: Add KDE Plasma 5.9.5
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.9.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 791f27194ec1..67812163e6dc 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.8.6.tar.xz 51160 SHA256 ccb22bc771940ec9b6ef7a742af18b8b456ccc05b50b1d29b8b9ecde4b8a076c SHA512 8046549ebd6f0085779de0cd4d85c79d1c03109925b87a3e6466909c006321dca658f95f82cd573cff5403662d47e067765b976221dc2f6172ad2f163973553e WHIRLPOOL b9398ee52dc4c73d373bcabc270a821627594cb0d934b0b3803a9f32e22dc1e16dad53d56720fc026c8e6fabde9ee1a36023dec2822e1b9eff6d38081e971b32
DIST plasma-integration-5.9.4.tar.xz 49904 SHA256 1569754b78cb57451360680316f3ce33f6eee643333a8eb0a8040512c44d65d6 SHA512 a51c3409407562a058c802a7c9fdd1d1340a261f8a88603b86301a8cb147ce113f45842be22d8c6e68ebaad8ca555dd4970504b4a81b2cbc9e2070b7eda57584 WHIRLPOOL 0475bb00ed4e8046ab61d29dd4cfc08e3a45b76242fd50a4a89220d3c03e2e51dd7b064926798677afa7721d7a367baa352921286cadf4e8de7f82e4cfb9294f
+DIST plasma-integration-5.9.5.tar.xz 49688 SHA256 1c84fdf4bd2d285485d0703248d3ae502443737f0cbc9870171560e872ce1d17 SHA512 5e69fb375b83cdc28230b9f1ff4a09ae2cdae3614ba2b7ab971d3d1666616eb7444c68e0065be927e8616c08a773f0b36ed9913f61066094a7a65f65174a8988 WHIRLPOOL 3d3a705ca1f00de7ed152adc6aed9d100b175027d0c874a40e521bf97a78a4f13c8d779235c6b86796f8f13a3516a8c31f02bdcdb5609019f038f385528fcb69
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.9.5.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.9.5.ebuild
new file mode 100644
index 000000000000..e50dd6194fb0
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.9.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui 'dbus' '' '5=')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"