summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-10-18 20:45:11 +0200
committerJohannes Huber <johu@gentoo.org>2016-10-18 20:48:44 +0200
commit5c4a81cccaffc851a883e17132287c4aca94b84a (patch)
tree447935b15fdda2ef3f77c0e5a42d81c2862af157 /kde-plasma/plasma-integration
parentmedia-libs/jasper: Add live ebuild (diff)
downloadgentoo-5c4a81cccaffc851a883e17132287c4aca94b84a.tar.gz
gentoo-5c4a81cccaffc851a883e17132287c4aca94b84a.tar.bz2
gentoo-5c4a81cccaffc851a883e17132287c4aca94b84a.zip
kde-plasma: Version bump KDE Plasma 5.8.2
Package-Manager: portage-2.3.2
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.8.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index d571b2ca5653..93c0b7cfdb7d 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.7.5.tar.xz 49240 SHA256 d41abdc63832d3fa1489aaec93dd382bb66e056982e3c49824f808f917f3ce16 SHA512 67b6b33e24b5e87b80694c7edd7d4daab8838f54a04922913c4138d55d02501d2dfe43c2718cdee4220dd194c424e50c83b711be5ee259ed58660b6c29d9e97f WHIRLPOOL 60d16269ea3ad267050c09337064ee25d98038314a5d007747cbf5970571f7c6cc6baeb1383e675ac741268133ce48a404d9f399d0dbf343aa57148444658728
DIST plasma-integration-5.8.1.tar.xz 50272 SHA256 c754aeed43dbf51c32094fe150d1243fcc4cd9817cc7e35765ccb157ac3dccf5 SHA512 ad507f158a07ff381b1c79f7bd6041f2d503860d944ae5f782363520dedf9598b63285d1ea69884a25ac31ae44e3a245f1861ec2ee471ebb3acd21fc0ff8ab8d WHIRLPOOL 2db455b52374fbde644b89cf18bb9f7842dd45071edfe166a8012c4fd7037667c559efde82dda4c11580fc85d43ff9d4a95c7fe37d239e5300b6ea375e2134e2
+DIST plasma-integration-5.8.2.tar.xz 50260 SHA256 2e13ec9fc4fd9d61e0328fb96218d42462ed79ca04134e760c4c517a6469f7fc SHA512 40ac0937f65df731a29a2173c2ebf4d15fd2ca9e370d2af5d3b44a3366ea2d9a4e217a404a9cd2f7d9aa75d33afa021eb9acf9be1769ef47f60d4deb13ed40f7 WHIRLPOOL 8e325603d3c2f65dc5dc50a949ca463ad4effcd48af42ec76ee2e62c8ab0dc97e5eae84825be360c88f699bd718289a76381e57d734ed868b577254026d2227f
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.8.2.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.8.2.ebuild
new file mode 100644
index 000000000000..2805c9b63a61
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.8.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"