summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /lxde-base/lxde-common
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'lxde-base/lxde-common')
-rw-r--r--lxde-base/lxde-common/Manifest1
-rw-r--r--lxde-base/lxde-common/files/lxde90
-rw-r--r--lxde-base/lxde-common/files/lxde-common-0.5.0-desktop-icons.patch8
-rw-r--r--lxde-base/lxde-common/files/lxde-common-0.5.0-session-fix.patch11
-rw-r--r--lxde-base/lxde-common/files/lxde-common-0.5.5-logout.patch14
-rw-r--r--lxde-base/lxde-common/lxde-common-0.5.5-r2.ebuild46
-rw-r--r--lxde-base/lxde-common/lxde-common-0.5.5-r3.ebuild47
-rw-r--r--lxde-base/lxde-common/metadata.xml8
8 files changed, 225 insertions, 0 deletions
diff --git a/lxde-base/lxde-common/Manifest b/lxde-base/lxde-common/Manifest
new file mode 100644
index 000000000000..4dbbc8f49b92
--- /dev/null
+++ b/lxde-base/lxde-common/Manifest
@@ -0,0 +1 @@
+DIST lxde-common-0.5.5.tar.gz 899075 SHA256 ee18a09b64a442b33c1b54f0269649a1b4d9490460c400a07ed785d41bf6dde6 SHA512 44848286ccf3aa269df1680e14a8d3c41be1c2af956bd5121fc05d97a892fdc13d1e74191a2a11a40e96a8f31f8be37b1cfb9afeac4474fcab88d07508647c7f WHIRLPOOL 60423eb159fabba12394609b7538e63342c8c39ca38be441d930923deb25116ff1bc0e01d6aa25cfd53d202b426cd9b9fac9410de9c07f211e1b753fe44d4264
diff --git a/lxde-base/lxde-common/files/lxde b/lxde-base/lxde-common/files/lxde
new file mode 100644
index 000000000000..489ce2d1fe32
--- /dev/null
+++ b/lxde-base/lxde-common/files/lxde
@@ -0,0 +1,90 @@
+#!/bin/sh
+# LXDE Xsession starter, based on Xsession shipped by x11-apps/xinit-1.0.5-r1
+
+# redirect errors to a file in user's home directory if we can
+for errfile in "$HOME/.lxde-errors" "${TMPDIR-/tmp}/lxde-$USER" "/tmp/lxde-$USER"
+do
+ if ( cp /dev/null "$errfile" 2> /dev/null )
+ then
+ chmod 600 "$errfile"
+ exec > "$errfile" 2>&1
+ break
+ fi
+done
+
+userresources=$HOME/.Xresources
+usermodmap=$HOME/.Xmodmap
+userxkbmap=$HOME/.Xkbmap
+
+sysresources=/etc/X11/Xresources
+sysmodmap=/etc/X11/Xmodmap
+sysxkbmap=/etc/X11/Xkbmap
+
+rh6sysresources=/etc/X11/xinit/Xresources
+rh6sysmodmap=/etc/X11/xinit/Xmodmap
+
+
+# merge in defaults
+if [ -f "$rh6sysresources" ]; then
+ xrdb -merge "$rh6sysresources"
+fi
+
+if [ -f "$sysresources" ]; then
+ xrdb -merge "$sysresources"
+fi
+
+if [ -f "$userresources" ]; then
+ xrdb -merge "$userresources"
+fi
+
+# merge in keymaps
+if [ -f "$sysxkbmap" ]; then
+ setxkbmap `cat "$sysxkbmap"`
+ XKB_IN_USE=yes
+fi
+
+if [ -f "$userxkbmap" ]; then
+ setxkbmap `cat "$userxkbmap"`
+ XKB_IN_USE=yes
+fi
+
+#
+# Eeek, this seems like too much magic here
+#
+if [ -z "$XKB_IN_USE" -a ! -L /etc/X11/X ]; then
+ if grep '^exec.*/Xsun' /etc/X11/X > /dev/null 2>&1 && [ -f /etc/X11/XF86Config ]; then
+ xkbsymbols=`sed -n -e 's/^[ ]*XkbSymbols[ ]*"\(.*\)".*$/\1/p' /etc/X11/XF86Config /etc/X11/xorg.conf`
+ if [ -n "$xkbsymbols" ]; then
+ setxkbmap -symbols "$xkbsymbols"
+ XKB_IN_USE=yes
+ fi
+ fi
+fi
+
+# xkb and xmodmap don't play nice together
+if [ -z "$XKB_IN_USE" ]; then
+ if [ -f "$rh6sysmodmap" ]; then
+ xmodmap "$rh6sysmodmap"
+ fi
+
+ if [ -f "$sysmodmap" ]; then
+ xmodmap "$sysmodmap"
+ fi
+
+ if [ -f "$usermodmap" ]; then
+ xmodmap "$usermodmap"
+ fi
+fi
+
+unset XKB_IN_USE
+
+# run all system xinitrc shell scripts.
+if [ -d /etc/X11/xinit/xinitrc.d ]; then
+ for i in /etc/X11/xinit/xinitrc.d/* ; do
+ if [ -x "$i" ]; then
+ . "$i"
+ fi
+ done
+fi
+
+exec /usr/bin/startlxde
diff --git a/lxde-base/lxde-common/files/lxde-common-0.5.0-desktop-icons.patch b/lxde-base/lxde-common/files/lxde-common-0.5.0-desktop-icons.patch
new file mode 100644
index 000000000000..c751ae64dba3
--- /dev/null
+++ b/lxde-base/lxde-common/files/lxde-common-0.5.0-desktop-icons.patch
@@ -0,0 +1,8 @@
+diff -NrU5 lxde-common-0.5.0.original/autostart lxde-common-0.5.0/autostart
+--- lxde-common-0.5.0.original/autostart 2009-07-14 13:39:53.000000000 +0200
++++ lxde-common-0.5.0/autostart 2010-07-29 15:42:14.585488801 +0200
+@@ -1,3 +1,3 @@
+ @xscreensaver -no-splash
+ @lxpanel --profile LXDE
+-@pcmanfm -d
++@pcmanfm --desktop
diff --git a/lxde-base/lxde-common/files/lxde-common-0.5.0-session-fix.patch b/lxde-base/lxde-common/files/lxde-common-0.5.0-session-fix.patch
new file mode 100644
index 000000000000..23a5438f032a
--- /dev/null
+++ b/lxde-base/lxde-common/files/lxde-common-0.5.0-session-fix.patch
@@ -0,0 +1,11 @@
+diff -NrU5 lxde-common-0.5.0.original/startlxde.in lxde-common-0.5.0/startlxde.in
+--- lxde-common-0.5.0.original/startlxde.in 2010-01-21 09:18:33.000000000 -0600
++++ lxde-common-0.5.0/startlxde.in 2010-01-21 09:19:12.000000000 -0600
+@@ -23,6 +23,6 @@
+
+ # Enable GTK+2 integration for OpenOffice.org, if available.
+ export SAL_USE_VCLPLUGIN=gtk
+
+ # Start the LXDE session
+-exec @prefix@/bin/lxsession -s LXDE
++exec @prefix@/bin/lxsession -s LXDE -e LXDE
diff --git a/lxde-base/lxde-common/files/lxde-common-0.5.5-logout.patch b/lxde-base/lxde-common/files/lxde-common-0.5.5-logout.patch
new file mode 100644
index 000000000000..129fb9a5b1ad
--- /dev/null
+++ b/lxde-base/lxde-common/files/lxde-common-0.5.5-logout.patch
@@ -0,0 +1,14 @@
+Index: lxde-common-0.5.5/Makefile.am
+===================================================================
+--- lxde-common-0.5.5.orig/Makefile.am
++++ lxde-common-0.5.5/Makefile.am
+@@ -20,6 +20,9 @@ images_DATA= \
+ images/logout-banner.png \
+ images/lxde-icon.png
+
++lxlogoutdir=$(datadir)/applications/
++lxlogout_DATA=lxde-logout.desktop
++
+ lxpaneldir=$(datadir)/lxpanel/profile/LXDE
+ lxpanel_DATA=lxpanel/config
+
diff --git a/lxde-base/lxde-common/lxde-common-0.5.5-r2.ebuild b/lxde-base/lxde-common/lxde-common-0.5.5-r2.ebuild
new file mode 100644
index 000000000000..85496ca838d5
--- /dev/null
+++ b/lxde-base/lxde-common/lxde-common-0.5.5-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="LXDE Session default configuration files and nuoveXT2 iconset"
+HOMEPAGE="http://lxde.sf.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+PDEPEND="lxde-base/lxde-icon-theme"
+
+src_prepare() {
+ #bug 380043
+ epatch "${FILESDIR}"/${P}-logout.patch
+
+ # Rerun autotools
+ einfo "Regenerating autotools files..."
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ # install session file
+ insinto /etc/X11/Sessions/
+ doins ${FILESDIR}/lxde
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ elog "${P} has renamed the configuration file name to"
+ elog "/etc/xdg/lxsession/LXDE/desktop.conf"
+ elog "Keep in mind you have to migrate your custom settings"
+ elog "from /etc/xdg/lxsession/LXDE/config"
+}
diff --git a/lxde-base/lxde-common/lxde-common-0.5.5-r3.ebuild b/lxde-base/lxde-common/lxde-common-0.5.5-r3.ebuild
new file mode 100644
index 000000000000..52c95616114b
--- /dev/null
+++ b/lxde-base/lxde-common/lxde-common-0.5.5-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="LXDE Session default configuration files and nuoveXT2 iconset"
+HOMEPAGE="http://lxde.sf.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ppc x86 ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+PDEPEND="lxde-base/lxde-icon-theme"
+
+src_prepare() {
+ #bug 380043
+ epatch "${FILESDIR}"/${P}-logout.patch
+
+ # Rerun autotools
+ einfo "Regenerating autotools files..."
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ # install session file
+ insinto /etc/X11/Sessions/
+ doins ${FILESDIR}/lxde
+ fperms 755 /etc/X11/Sessions/lxde
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ elog "${P} has renamed the configuration file name to"
+ elog "/etc/xdg/lxsession/LXDE/desktop.conf"
+ elog "Keep in mind you have to migrate your custom settings"
+ elog "from /etc/xdg/lxsession/LXDE/config"
+}
diff --git a/lxde-base/lxde-common/metadata.xml b/lxde-base/lxde-common/metadata.xml
new file mode 100644
index 000000000000..831327e101a9
--- /dev/null
+++ b/lxde-base/lxde-common/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxde</herd>
+ <upstream>
+ <remote-id type="sourceforge">lxde</remote-id>
+ </upstream>
+</pkgmetadata>