summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-05-25 21:11:10 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-05-26 09:31:16 -0400
commit4b66dd8777f8181257441d8c3f33ac3b8aeb3e43 (patch)
treeaf6cd586d953e0f37f5c4f99c2470271b9f5e79b /mail-filter
parentnet-misc/apt-cacher-ng: Fix expire-caller.pl, disable by default (diff)
downloadgentoo-4b66dd8777f8181257441d8c3f33ac3b8aeb3e43.tar.gz
gentoo-4b66dd8777f8181257441d8c3f33ac3b8aeb3e43.tar.bz2
gentoo-4b66dd8777f8181257441d8c3f33ac3b8aeb3e43.zip
mail-filter/pypolicyd-spf: hard-code PN before a pkgmove.
This package was renamed to spf-engine. This commit hard-codes the package name "pypolicyd-spf" in the existing stable ebuild so that it survives the rename. Bug: https://bugs.gentoo.org/724526 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.2-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.2-r1.ebuild b/mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.2-r1.ebuild
index aa46887f9be9..da8cc8d6ff55 100644
--- a/mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.2-r1.ebuild
+++ b/mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.2-r1.ebuild
@@ -14,9 +14,12 @@ PYTHON_REQ_USE="ipv6"
DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
+OLD_PN="pypolicyd-spf"
+OLD_P="${OLD_PN}-${PV}"
+OLD_PF="${PN}-${PVR}"
DESCRIPTION="Python-based policy daemon for Postfix SPF verification"
HOMEPAGE="https://launchpad.net/pypolicyd-spf"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+SRC_URI="mirror://pypi/p/${OLD_PN}/${OLD_P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
@@ -28,13 +31,15 @@ DEPEND="dev-python/pyspf[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
dev-python/authres[${PYTHON_USEDEP}]"
+S="${WORKDIR}/${OLD_P}"
+
DOCS=( CHANGES policyd-spf.conf.commented README README.per_user_whitelisting )
python_prepare_all() {
# The "real" config file mentions the commented one, so we point
# users in the right direction.
local oldconf="policyd-spf.conf.commented"
- local newconf="/usr/share/doc/${PF}/${oldconf}"
+ local newconf="/usr/share/doc/${OLD_PF}/${oldconf}"
sed -i "1 s~ ${oldconf}~,\n# ${newconf}~" policyd-spf.conf \
|| die 'failed to update commented config file path'