summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-09-04 20:20:04 -0400
committerEttore Di Giacinto <mudler@gentoo.org>2016-11-21 12:00:09 +0100
commitb3ed19b133e9d6403c9e9f1d3a9f07f3fb756f4e (patch)
treedfafdb93d06b16e96b1d828c585a0fa14967cfbf /mate-extra
parentmate-extra/mate-power-manager: Version bump to 1.14.0 (diff)
downloadgentoo-b3ed19b133e9d6403c9e9f1d3a9f07f3fb756f4e.tar.gz
gentoo-b3ed19b133e9d6403c9e9f1d3a9f07f3fb756f4e.tar.bz2
gentoo-b3ed19b133e9d6403c9e9f1d3a9f07f3fb756f4e.zip
mate-extra/mate-system-monitor: Bump to 1.14.0, pkg_postinst for gksu
Package-Manager: portage-2.3.0
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-system-monitor/Manifest1
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.14.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/mate-extra/mate-system-monitor/Manifest b/mate-extra/mate-system-monitor/Manifest
index c2c5cd22a34a..f41d5b596165 100644
--- a/mate-extra/mate-system-monitor/Manifest
+++ b/mate-extra/mate-system-monitor/Manifest
@@ -1,2 +1,3 @@
DIST mate-system-monitor-1.10.1.tar.xz 2129620 SHA256 d5428990f9ba2a864a9c4af74c626c3e8f46f0b0468925209ad51f2d09304774 SHA512 a80922315d387eda99223ecc6f44a7608a3ef2d300ef80f10e35aede83783407f996935f7e106d342dcd91b8681158b587a5c1d1192724040e6bd99409cae6ec WHIRLPOOL 0e2f4d2e8884d3f6e4dcd1caf3b81866d2e7d0cd2dad679c3201ebd37afcb038c14df1a2245aa4b5e3fcade08243c2ad7a4a9d1745b758c4d57ba6f8ce55f4b4
DIST mate-system-monitor-1.12.2.tar.xz 2114504 SHA256 78b91ae43fd0f06e0577d71d3b92b9c03ff2dc8809ba2b06dc0c4dc9e93683f5 SHA512 f001d36b7a343cba68bf76094abad4e07cc89537c71dba873bb5ffc61045f440a319e3db8d5ee55ff301f52dbdad8b275ca71a4ab6c5fbe34d75c2e65edd7c23 WHIRLPOOL 7270766f4434cb0e489f3f1ef805586987751fbea6a0a020df8fa7fa38dbbf264d0d1f3694fbba8e9d14cf2ddaee217ac562a391b4b87f1033cf2850067ae1a0
+DIST mate-system-monitor-1.14.0.tar.xz 2135464 SHA256 ccd7f52836af22d18138e516335ee259448749b6618327feb908ad396d0c650a SHA512 f19fa0241228be8ec8600db43e71495750039288292ba5714489a84acb3e5cc9f4c87d39a63d29a0fc6f907af6ecc319382cd4276ae2de1125bba059d5b24be5 WHIRLPOOL d354dfbf7121b838af6fac73148e381c23df4e3bc50a59f68f6469416f608235a0b6d990214e9de87bc01e1254f16e1ba9d1f631e18554205ae45ebc4b84f149
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.14.0.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.14.0.ebuild
new file mode 100644
index 000000000000..4f6f946a9d52
--- /dev/null
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.14.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="The MATE System Monitor"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="systemd"
+
+COMMON_DEPEND="
+ >=dev-cpp/glibmm-2.26:2
+ >=dev-cpp/gtkmm-3.8:3.0
+ >=dev-libs/glib-2.36:2
+ dev-libs/libsigc++:2
+ >=dev-libs/libxml2-2:2
+ >=gnome-base/libgtop-2.23.1:2=
+ >=gnome-base/librsvg-2.35:2
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.14:3
+ >=x11-libs/libwnck-3.0:3
+ virtual/libintl:0
+ systemd? ( sys-apps/systemd )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ >=sys-devel/autoconf-2.63:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable systemd)
+}
+
+pkg_postinst() {
+ mate_pkg_postinst
+
+ einfo "${PN} may run commands with escalated privileges using"
+ einfo "x11-libs/gksu."
+}