summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/fbgrab/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/fbgrab/files')
-rw-r--r--media-gfx/fbgrab/files/fbgrab-1.0-Makefile.patch14
-rw-r--r--media-gfx/fbgrab/files/fbgrab-1.0-zlib_h.patch10
-rw-r--r--media-gfx/fbgrab/files/fbgrab-1.1-Makefile.patch12
3 files changed, 36 insertions, 0 deletions
diff --git a/media-gfx/fbgrab/files/fbgrab-1.0-Makefile.patch b/media-gfx/fbgrab/files/fbgrab-1.0-Makefile.patch
new file mode 100644
index 000000000000..28fa840aa33a
--- /dev/null
+++ b/media-gfx/fbgrab/files/fbgrab-1.0-Makefile.patch
@@ -0,0 +1,14 @@
+diff -ru fbgrab-1.0.origin/Makefile fbgrab-1.0/Makefile
+--- fbgrab-1.0.origin/Makefile 2002-03-20 22:49:06.000000000 +0300
++++ fbgrab-1.0/Makefile 2013-06-25 21:03:11.000000000 +0400
+@@ -4,8 +4,8 @@
+ ###
+
+ fbgrab: fbgrab.c
+- splint +posixlib fbgrab.c
+- gcc -g -Wall fbgrab.c -lpng -lz -o fbgrab
++ #splint +posixlib fbgrab.c
++ $(CC) -Wall ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} fbgrab.c -lpng -lz -o fbgrab
+
+ install:
+ strip fbgrab
diff --git a/media-gfx/fbgrab/files/fbgrab-1.0-zlib_h.patch b/media-gfx/fbgrab/files/fbgrab-1.0-zlib_h.patch
new file mode 100644
index 000000000000..8318ab468994
--- /dev/null
+++ b/media-gfx/fbgrab/files/fbgrab-1.0-zlib_h.patch
@@ -0,0 +1,10 @@
+--- fbgrab.c
++++ fbgrab.c
+@@ -22,6 +22,7 @@
+
+ #include <getopt.h>
+ #include <sys/vt.h> /* to handle vt changing */
++#include <zlib.h> /* Z_BEST_COMPRESSION */
+ #include <png.h> /* PNG lib */
+ #include <linux/fb.h> /* to handle framebuffer ioctls */
+
diff --git a/media-gfx/fbgrab/files/fbgrab-1.1-Makefile.patch b/media-gfx/fbgrab/files/fbgrab-1.1-Makefile.patch
new file mode 100644
index 000000000000..5280a0a1e516
--- /dev/null
+++ b/media-gfx/fbgrab/files/fbgrab-1.1-Makefile.patch
@@ -0,0 +1,12 @@
+diff -ru fbgrab.orig/Makefile fbgrab/Makefile
+--- fbgrab.orig/Makefile 2013-05-24 00:14:45.000000000 +0400
++++ fbgrab/Makefile 2013-08-22 14:39:18.000000000 +0400
+@@ -4,7 +4,7 @@
+ ###
+
+ fbgrab: fbgrab.c
+- gcc -g -Wall fbgrab.c -lpng -lz -o fbgrab
++ $(CC) -Wall ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} fbgrab.c -lpng -lz -o fbgrab
+
+ install:
+ install fbgrab /usr/bin/fbgrab