summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/povtree
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/povtree')
-rw-r--r--media-gfx/povtree/Manifest1
-rw-r--r--media-gfx/povtree/files/povtree12
-rw-r--r--media-gfx/povtree/metadata.xml5
-rw-r--r--media-gfx/povtree/povtree-1.5-r1.ebuild29
4 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/povtree/Manifest b/media-gfx/povtree/Manifest
new file mode 100644
index 000000000000..84c254407440
--- /dev/null
+++ b/media-gfx/povtree/Manifest
@@ -0,0 +1 @@
+DIST povtree1.5.zip 917548 SHA256 d846e45ad77fe0a5501b46f40c1b2596161d59a51884c67af753d339143ad333 SHA512 ef8de1e1d9b5ffde782bd6bba39a11b57928bdb2b3359613a0ae1bc6ad012876a3a80d8cbbba1df77b366e44a7d2f0b48929f12e18853ec556f5af5780ea7d34 WHIRLPOOL 90cd76777217dd870220a7aebe3c12dc568a9c19877308ed1d56c024660e861819a1c535b38ada2154b3e057186b80865689756b9232dc30e4127fc02deb9e29
diff --git a/media-gfx/povtree/files/povtree b/media-gfx/povtree/files/povtree
new file mode 100644
index 000000000000..a4f041c21d5d
--- /dev/null
+++ b/media-gfx/povtree/files/povtree
@@ -0,0 +1,12 @@
+#!/bin/sh
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+which java > /dev/null 2>&1 && \
+ java -jar /usr/lib/povtree/povtree.jar $* && \
+ exit 0
+
+echo "No \"java\" binary found in your PATH."
+echo "You should run \"java-config\" to choose your default VM."
+exit 1
diff --git a/media-gfx/povtree/metadata.xml b/media-gfx/povtree/metadata.xml
new file mode 100644
index 000000000000..e770d1bc9a96
--- /dev/null
+++ b/media-gfx/povtree/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+</pkgmetadata>
diff --git a/media-gfx/povtree/povtree-1.5-r1.ebuild b/media-gfx/povtree/povtree-1.5-r1.ebuild
new file mode 100644
index 000000000000..9326d2fbec7d
--- /dev/null
+++ b/media-gfx/povtree/povtree-1.5-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+S="${WORKDIR}"
+MY_P="${PN}${PV}"
+DESCRIPTION="Tree generator for POVray based on TOMTREE macro"
+HOMEPAGE="http://propro.ru/go/Wshop/povtree/povtree.html"
+SRC_URI="http://propro.ru/go/Wshop/povtree/${MY_P}.zip"
+
+# Free for non-commercial use, according to e-mail from authors #446168
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+RDEPEND=">=virtual/jre-1.3"
+DEPEND="app-arch/unzip"
+
+src_install() {
+ # wrapper
+ sed "s:/usr/:${EPREFIX}&:" "${FILESDIR}"/povtree > "${T}"/povtree || die
+ dobin "${T}"/povtree
+ # package
+ insinto /usr/lib/povtree
+ doins povtree.jar
+ dodoc TOMTREE-${PV}.inc help.jpg
+}