summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-10 21:28:20 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-10 21:28:42 -0400
commitd28899acdcc9c274e1a80b4c65fc88f938c46b8d (patch)
treed416c8048b60218e1915f92d9e27aa122ec61d68 /media-gfx
parentmedia-gfx/xdot: Depend on gtk+[X] for tests (diff)
downloadgentoo-d28899acdcc9c274e1a80b4c65fc88f938c46b8d.tar.gz
gentoo-d28899acdcc9c274e1a80b4c65fc88f938c46b8d.tar.bz2
gentoo-d28899acdcc9c274e1a80b4c65fc88f938c46b8d.zip
media-gfx/xdot: Bump to EAPI=8
* switch to DISTUTILS_USE_PEP517=setuptools * propagate keywords * Move gtk+ test dependency from DEPEND+RDEPEND to DEPEND-only Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/xdot/xdot-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/media-gfx/xdot/xdot-9999.ebuild b/media-gfx/xdot/xdot-9999.ebuild
index 248915833b80..6b9cdbea7cf7 100644
--- a/media-gfx/xdot/xdot-9999.ebuild
+++ b/media-gfx/xdot/xdot-9999.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )
MY_PN=xdot.py
@@ -11,7 +13,7 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
SRC_URI=""
else
- KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
MY_P="${MY_PN}-${PV}"
S="${WORKDIR}/${MY_P}"
SRC_URI="https://github.com/jrfonseca/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -25,14 +27,16 @@ HOMEPAGE="https://github.com/jrfonseca/xdot.py"
LICENSE="LGPL-2+"
SLOT="0"
-DEPEND="
+RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
media-gfx/graphviz
+"
+DEPEND="
+ ${RDEPEND}
test? ( x11-libs/gtk+:3[X] )
"
-RDEPEND="${DEPEND}"
run_test() {
cd tests && "${EPYTHON}" ../test.py *.dot graphs/*.gv