summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/atlas-c++
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/atlas-c++')
-rw-r--r--media-libs/atlas-c++/Manifest1
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.6.3.ebuild42
-rw-r--r--media-libs/atlas-c++/files/atlas-c++-0.6.1-as-needed.patch63
-rw-r--r--media-libs/atlas-c++/files/atlas-c++-0.6.1-gcc-4.3.patch30
-rw-r--r--media-libs/atlas-c++/files/atlas-c++-0.6.1-gcc-4.4.patch10
-rw-r--r--media-libs/atlas-c++/files/atlas-c++-0.6.1-strict-aliasing.patch16
-rw-r--r--media-libs/atlas-c++/files/atlas-c++-0.6.2-Werror.patch15
-rw-r--r--media-libs/atlas-c++/files/atlas-c++-0.6.3-Werror.patch15
-rw-r--r--media-libs/atlas-c++/metadata.xml15
9 files changed, 207 insertions, 0 deletions
diff --git a/media-libs/atlas-c++/Manifest b/media-libs/atlas-c++/Manifest
new file mode 100644
index 000000000000..8a08161e09a6
--- /dev/null
+++ b/media-libs/atlas-c++/Manifest
@@ -0,0 +1 @@
+DIST Atlas-C++-0.6.3.tar.bz2 527537 SHA256 5b8401a3b1182eb413b7fe4e6791c14343e7d7b7af6426d5279c6b9cf681f6a3 SHA512 3063a7fabbd5937cd4c9be72596a2fd1885a8ed8e8586f0014077a40477d124b3222280bb26f2034fa2e23aed14a1c6fa800cc40636af986a78a71d68ed40606 WHIRLPOOL 1549bb8726b711758359aee864d1c29b7724d06046fdb2a12af560a0220016727e7b8160eba2b1ac0894a764e4feb9fbaaf5008487350863360d3fe6a0b28bd2
diff --git a/media-libs/atlas-c++/atlas-c++-0.6.3.ebuild b/media-libs/atlas-c++/atlas-c++-0.6.3.ebuild
new file mode 100644
index 000000000000..60b826e92c04
--- /dev/null
+++ b/media-libs/atlas-c++/atlas-c++-0.6.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+inherit eutils autotools
+
+MY_PN="Atlas-C++"
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Atlas protocol, used in role playing games at worldforge"
+HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/atlas_cpp"
+SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Werror.patch
+ eautoreconf
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ emake docs
+ fi
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/html/*
+ use doc && doman doc/man/man3/[^i]*
+ dodoc HACKING ROADMAP
+}
diff --git a/media-libs/atlas-c++/files/atlas-c++-0.6.1-as-needed.patch b/media-libs/atlas-c++/files/atlas-c++-0.6.1-as-needed.patch
new file mode 100644
index 000000000000..c89827be08e9
--- /dev/null
+++ b/media-libs/atlas-c++/files/atlas-c++-0.6.1-as-needed.patch
@@ -0,0 +1,63 @@
+--- Atlas/Makefile.am.old 2008-11-20 08:45:41.000000000 +0100
++++ Atlas/Makefile.am 2008-11-20 08:45:52.000000000 +0100
+@@ -1,4 +1,4 @@
+-SUBDIRS = Message Codecs Filters Net Objects Funky
++SUBDIRS = . Message Codecs Filters Net Objects Funky
+
+ INCLUDES = -I$(top_srcdir)
+
+--- Atlas/Message/Makefile.am.old 2008-11-20 08:47:01.000000000 +0100
++++ Atlas/Message/Makefile.am 2008-11-20 08:47:29.000000000 +0100
+@@ -5,6 +5,8 @@
+
+ libAtlasMessage_0_6_la_LDFLAGS = $(INTERFACE_VERSION)
+
++libAtlasMessage_0_6_la_LIBADD = ../libAtlas-0.6.la
++
+ libAtlasMessage_0_6_la_SOURCES = \
+ Element.cpp MEncoder.cpp DecoderBase.cpp QueuedDecoder.cpp
+
+--- Atlas/Codecs/Makefile.am.old 2008-11-20 08:49:49.000000000 +0100
++++ Atlas/Codecs/Makefile.am 2008-11-20 08:52:45.000000000 +0100
+@@ -5,6 +5,8 @@
+
+ libAtlasCodecs_0_6_la_LDFLAGS = $(INTERFACE_VERSION)
+
++libAtlasCodecs_0_6_la_LIBADD = ../libAtlas-0.6.la
++
+ libAtlasCodecs_0_6_la_SOURCES = \
+ Utility.cpp XML.cpp Packed.cpp Bach.cpp
+
+--- Atlas/Filters/Makefile.am.old 2008-11-20 08:53:58.000000000 +0100
++++ Atlas/Filters/Makefile.am 2008-11-20 08:55:21.000000000 +0100
+@@ -5,6 +5,8 @@
+
+ libAtlasFilters_0_6_la_LDFLAGS = $(INTERFACE_VERSION)
+
++libAtlasFilters_0_6_la_LIBADD = ../libAtlas-0.6.la -lz -lbz2
++
+ libAtlasFilters_0_6_la_SOURCES = \
+ Bzip2.cpp Bzip2.h \
+ Gzip.cpp Gzip.h
+--- Atlas/Net/Makefile.am.old 2008-11-19 15:10:38.000000000 +0100
++++ Atlas/Net/Makefile.am 2008-11-19 15:11:13.000000000 +0100
+@@ -5,6 +5,8 @@
+
+ libAtlasNet_0_6_la_LDFLAGS = $(INTERFACE_VERSION)
+
++libAtlasNet_0_6_la_LIBADD = ../Codecs/libAtlasCodecs-0.6.la ../libAtlas-0.6.la
++
+ libAtlasNetincludedir = $(includedir)/Atlas-C++-0.6/Atlas/Net
+
+ libAtlasNet_0_6_la_SOURCES = \
+--- Atlas/Objects/Makefile.am.old 2008-11-20 08:57:39.000000000 +0100
++++ Atlas/Objects/Makefile.am 2008-11-20 08:58:56.000000000 +0100
+@@ -5,6 +5,8 @@
+
+ libAtlasObjects_0_6_la_LDFLAGS = $(INTERFACE_VERSION)
+
++libAtlasObjects_0_6_la_LIBADD = ../libAtlas-0.6.la ../Message/libAtlasMessage-0.6.la ../Codecs/libAtlasCodecs-0.6.la
++
+ REAL_GENERATED_CPP = Root.cpp Decoder.cpp Dispatcher.cpp objectFactory.cpp \
+ RootEntity.cpp RootEntityChildren.cpp \
+ RootOperation.cpp RootOperationChildren1.cpp \
diff --git a/media-libs/atlas-c++/files/atlas-c++-0.6.1-gcc-4.3.patch b/media-libs/atlas-c++/files/atlas-c++-0.6.1-gcc-4.3.patch
new file mode 100644
index 000000000000..6ac1bc6e6194
--- /dev/null
+++ b/media-libs/atlas-c++/files/atlas-c++-0.6.1-gcc-4.3.patch
@@ -0,0 +1,30 @@
+--- Atlas/Filter.cpp.old 2008-04-14 23:55:23.000000000 +0200
++++ Atlas/Filter.cpp 2008-04-14 23:57:04.000000000 +0200
+@@ -4,6 +4,8 @@
+
+ #include <Atlas/Filter.h>
+
++#include <string.h>
++
+ namespace Atlas {
+
+ Filter::Filter(Filter* next)
+@@ -41,7 +43,7 @@
+
+ if (numPutback > m_inPutback) numPutback = m_inPutback;
+
+- std::memcpy(m_outBuffer + (m_inPutback - numPutback),
++ ::memcpy(m_outBuffer + (m_inPutback - numPutback),
+ gptr() - numPutback,
+ (unsigned long) numPutback);
+
+--- tools/atlas_convert.cpp.old 2008-04-14 23:58:53.000000000 +0200
++++ tools/atlas_convert.cpp 2008-04-14 23:59:15.000000000 +0200
+@@ -14,6 +14,7 @@
+ #include <fstream>
+ #include <iostream>
+
++#include <stdlib.h>
+ #include <unistd.h>
+
+ int option_format = 0;
diff --git a/media-libs/atlas-c++/files/atlas-c++-0.6.1-gcc-4.4.patch b/media-libs/atlas-c++/files/atlas-c++-0.6.1-gcc-4.4.patch
new file mode 100644
index 000000000000..ed792935349a
--- /dev/null
+++ b/media-libs/atlas-c++/files/atlas-c++-0.6.1-gcc-4.4.patch
@@ -0,0 +1,10 @@
+--- Atlas/Filter.cpp.old 2009-07-06 09:58:04.000000000 +0200
++++ Atlas/Filter.cpp 2009-07-06 09:58:44.000000000 +0200
+@@ -5,6 +5,7 @@
+ #include <Atlas/Filter.h>
+
+ #include <string.h>
++#include <cstdio>
+
+ namespace Atlas {
+
diff --git a/media-libs/atlas-c++/files/atlas-c++-0.6.1-strict-aliasing.patch b/media-libs/atlas-c++/files/atlas-c++-0.6.1-strict-aliasing.patch
new file mode 100644
index 000000000000..edf1ac197755
--- /dev/null
+++ b/media-libs/atlas-c++/files/atlas-c++-0.6.1-strict-aliasing.patch
@@ -0,0 +1,16 @@
+--- tests/Objects/Makefile.am.old 2008-02-29 07:43:45.000000000 +0100
++++ tests/Objects/Makefile.am 2008-02-29 07:44:21.000000000 +0100
+@@ -28,3 +28,5 @@
+ attributes_SOURCES = attributes.cpp
+
+ flags_SOURCES = flags.cpp
++
++AM_CPPFLAGS = -fno-strict-aliasing
+--- benchmark/Makefile.am.old 2008-02-29 07:57:10.000000000 +0100
++++ benchmark/Makefile.am 2008-02-29 07:57:33.000000000 +0100
+@@ -31,3 +31,5 @@
+
+ Objects_asMessage_SOURCES = Objects_asMessage.cpp timer.h
+ Objects_iterator_SOURCES = Objects_iterator.cpp timer.h
++
++AM_CPPFLAGS = -fno-strict-aliasing
diff --git a/media-libs/atlas-c++/files/atlas-c++-0.6.2-Werror.patch b/media-libs/atlas-c++/files/atlas-c++-0.6.2-Werror.patch
new file mode 100644
index 000000000000..b13384ab5a12
--- /dev/null
+++ b/media-libs/atlas-c++/files/atlas-c++-0.6.2-Werror.patch
@@ -0,0 +1,15 @@
+--- configure.ac.old 2011-05-02 11:16:53.851733207 +0200
++++ configure.ac 2011-05-02 11:17:18.489283901 +0200
+@@ -35,10 +35,10 @@
+ if test "$enableval" = "yes"; then
+ CXXFLAGS="$CXXFLAGS -Wall -Werror -DDEBUG"
+ else
+- CXXFLAGS="$CXXFLAGS -Wall -Werror -DNDEBUG"
++ CXXFLAGS="$CXXFLAGS -Wall -DNDEBUG"
+ fi
+ ],[
+- CXXFLAGS="$CXXFLAGS -Wall -Werror -DNDEBUG"
++ CXXFLAGS="$CXXFLAGS -Wall -DNDEBUG"
+ ]
+ )
+
diff --git a/media-libs/atlas-c++/files/atlas-c++-0.6.3-Werror.patch b/media-libs/atlas-c++/files/atlas-c++-0.6.3-Werror.patch
new file mode 100644
index 000000000000..b13384ab5a12
--- /dev/null
+++ b/media-libs/atlas-c++/files/atlas-c++-0.6.3-Werror.patch
@@ -0,0 +1,15 @@
+--- configure.ac.old 2011-05-02 11:16:53.851733207 +0200
++++ configure.ac 2011-05-02 11:17:18.489283901 +0200
+@@ -35,10 +35,10 @@
+ if test "$enableval" = "yes"; then
+ CXXFLAGS="$CXXFLAGS -Wall -Werror -DDEBUG"
+ else
+- CXXFLAGS="$CXXFLAGS -Wall -Werror -DNDEBUG"
++ CXXFLAGS="$CXXFLAGS -Wall -DNDEBUG"
+ fi
+ ],[
+- CXXFLAGS="$CXXFLAGS -Wall -Werror -DNDEBUG"
++ CXXFLAGS="$CXXFLAGS -Wall -DNDEBUG"
+ ]
+ )
+
diff --git a/media-libs/atlas-c++/metadata.xml b/media-libs/atlas-c++/metadata.xml
new file mode 100644
index 000000000000..f276a0d5eb12
--- /dev/null
+++ b/media-libs/atlas-c++/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tupone@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+Atlas-C++ is the current C++ implementation of the Atlas protocol, a
+communications layer designed to be used in the WorldForge MMORPG gaming
+system.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">worldforge</remote-id>
+ </upstream>
+</pkgmetadata>