summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-04-07 12:31:34 +0200
committerPacho Ramos <pacho@gentoo.org>2019-04-07 12:31:50 +0200
commitf5897ec5bfe99fb0f29ec7a021771e0c0d2c4b68 (patch)
tree5ef42cc7f8ba5e93040c9a28103918d4c55dc53e /media-libs/ctl
parentdev-python/psutil: amd64 stable wrt bug #680858 (diff)
downloadgentoo-f5897ec5bfe99fb0f29ec7a021771e0c0d2c4b68.tar.gz
gentoo-f5897ec5bfe99fb0f29ec7a021771e0c0d2c4b68.tar.bz2
gentoo-f5897ec5bfe99fb0f29ec7a021771e0c0d2c4b68.zip
media-libs/ctl: Fix compat with newer openexr
Closes: https://bugs.gentoo.org/668454 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-libs/ctl')
-rw-r--r--media-libs/ctl/ctl-1.5.2-r1.ebuild7
-rw-r--r--media-libs/ctl/files/ctl-1.5.2-openexr-2.3.patch13
2 files changed, 18 insertions, 2 deletions
diff --git a/media-libs/ctl/ctl-1.5.2-r1.ebuild b/media-libs/ctl/ctl-1.5.2-r1.ebuild
index 55acc2744c99..07a248ff7ba3 100644
--- a/media-libs/ctl/ctl-1.5.2-r1.ebuild
+++ b/media-libs/ctl/ctl-1.5.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,6 +22,9 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/CTL-ctl-${PV}"
-PATCHES=( "${FILESDIR}/${P}-Use-GNUInstallDirs-and-fix-PkgConfig-files-1.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-Use-GNUInstallDirs-and-fix-PkgConfig-files-1.patch"
+ "${FILESDIR}/${P}-openexr-2.3.patch"
+)
mycmakeargs=( -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}" )
diff --git a/media-libs/ctl/files/ctl-1.5.2-openexr-2.3.patch b/media-libs/ctl/files/ctl-1.5.2-openexr-2.3.patch
new file mode 100644
index 000000000000..ac4ceb3e5487
--- /dev/null
+++ b/media-libs/ctl/files/ctl-1.5.2-openexr-2.3.patch
@@ -0,0 +1,13 @@
+Index: CTL-ctl-1.5.2/lib/IlmCtlSimd/CtlSimdInst.cpp
+===================================================================
+--- CTL-ctl-1.5.2.orig/lib/IlmCtlSimd/CtlSimdInst.cpp
++++ CTL-ctl-1.5.2/lib/IlmCtlSimd/CtlSimdInst.cpp
+@@ -189,7 +189,7 @@ SimdInst::executePath (SimdBoolMask &mas
+ REPLACE_EXC
+ (e, "\n" <<
+ xcontext.fileName() << ":" <<
+- inst->lineNumber() << ": " << e);
++ inst->lineNumber() << ": " << e.what());
+
+ throw e;
+ }