summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-01-09 22:42:57 +0300
committerIan Delaney <idella4@gentoo.org>2016-01-10 09:58:55 +0800
commit95b17a979efbb78a23484cbca6447e536552a1ac (patch)
tree0216b058ad2c1ec0157a31f7a24a6f30e9112f9f /media-libs/ffmpegsource
parentmedia-libs/ffmpegsource: add compiler check for C++11 support (diff)
downloadgentoo-95b17a979efbb78a23484cbca6447e536552a1ac.tar.gz
gentoo-95b17a979efbb78a23484cbca6447e536552a1ac.tar.bz2
gentoo-95b17a979efbb78a23484cbca6447e536552a1ac.zip
media-libs/ffmpegsource: verbump to 2.22 wrt bug 564524
Gentoo-Bug: 564524 Package-Manager: portage-2.2.26
Diffstat (limited to 'media-libs/ffmpegsource')
-rw-r--r--media-libs/ffmpegsource/Manifest1
-rw-r--r--media-libs/ffmpegsource/ffmpegsource-2.22.ebuild39
-rw-r--r--media-libs/ffmpegsource/files/ffmpegsource-2.22-add-missing-extern-C.patch27
-rw-r--r--media-libs/ffmpegsource/files/ffmpegsource-2.22-fix-pixfmt-define.patch31
-rw-r--r--media-libs/ffmpegsource/files/ffmpegsource-2.22-include-missing-header.patch22
5 files changed, 120 insertions, 0 deletions
diff --git a/media-libs/ffmpegsource/Manifest b/media-libs/ffmpegsource/Manifest
index c928826575e1..ab2fa50b5b41 100644
--- a/media-libs/ffmpegsource/Manifest
+++ b/media-libs/ffmpegsource/Manifest
@@ -1,3 +1,4 @@
DIST ffmpegsource-2.19.1.tar.gz 512381 SHA256 39c8a5f6c6735d10b3b0a3830f71ef0182b42e747cbceb6bf9b8dcc0532c99db SHA512 e6e9a49af8eb9c1f5a54db8a74879cefbd4876329b71b09ebf79fc6f25808a12cc020ebe275607773127b908c67fc7c92f264b49e02ce08ec209a7d94e9d3a67 WHIRLPOOL 469519aee1a7364e21bb988481e6709af8ee53d18cd5be4d00c148a5e0f940491d6c777d387d3fcdbf74fde5c3c6da843205dd378e7fb301f65981daddf71760
DIST ffmpegsource-2.20.tar.gz 539587 SHA256 c7d880172756c253f2c5673044dabf03c19890dcfe64da5104ee9f42a1a573a0 SHA512 77cfb027a6be21952700fadee66467d18bc0521569cf3d5eef3f7fd3ff9785ba1c6b7a251a5ccfb8b6e8dd965aef9928cf27459dca28591eeddd1fd5a2905295 WHIRLPOOL 321cc4a3ff37201def87bfb7596e84e76cb58fb05a43d99901eaca8f46f712fa4d86af9cdc65a24749c2715a4f52c9106ab2b24d7060cfe87f5401e520ac7fb1
+DIST ffmpegsource-2.22.tar.gz 487244 SHA256 7c5202fa2e49186fb3bb815e5b12ca71f05ec09cb707ffd9465852e21a06fdad SHA512 af92766f19b5db15c2f0b08e4d894e26bb66f93360b12461d37f38983a4e1916656514d52bf86f8a5def83207e2433d04f58384b1cf8f617ab19aafd2f0d7d56 WHIRLPOOL 2fb1b189ba573fd2e1f65e61cfa365201a419a3bb066ef54e06c07c5f8eabcfb93dc3191c860a8816a797eb9e47a62929a35c1c786a43712ab80ac2df69ee811
DIST ffms-2.17-src.tar.bz2 394862 SHA256 991f7a77982823afdcf0beb8961deddaf7dd0aea949249e51fbf51cb3314643d SHA512 18a7ccbc9a665c1293dc17dccf3253fc4cad4449fc774242b773360eacb4eceb3440cd0dedbf4dfca51b40c5b2759bdd8b524cfba38339aff2460967ef8f0aa3 WHIRLPOOL 4f7ab6b1897d78b4a67c1ae5a1fce1c0d657454d6174fd738dbf8f0ecf77a5e137b6d263be0a8feb6b65db7b7f6ba7d0f601d719e6edb0e68850bf9662b39cb9
diff --git a/media-libs/ffmpegsource/ffmpegsource-2.22.ebuild b/media-libs/ffmpegsource/ffmpegsource-2.22.ebuild
new file mode 100644
index 000000000000..4a8b2a3ef90d
--- /dev/null
+++ b/media-libs/ffmpegsource/ffmpegsource-2.22.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils flag-o-matic vcs-snapshot
+
+DESCRIPTION="A libav/ffmpeg based source library for easy frame accurate access"
+HOMEPAGE="https://github.com/FFMS/ffms2"
+SRC_URI="https://github.com/FFMS/ffms2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/4"
+KEYWORDS="~amd64 ~x86"
+IUSE="libav static-libs"
+
+RDEPEND="
+ sys-libs/zlib
+ !libav? ( >=media-video/ffmpeg-2.4:0= )
+ libav? ( >=media-video/libav-9:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-pixfmt-define.patch"
+ "${FILESDIR}/${P}-include-missing-header.patch"
+ "${FILESDIR}/${P}-add-missing-extern-C.patch"
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && ! test-flag-CXX -std=c++11; then
+ die "Your compiler lacks C++11 support. Use GCC>=4.7.0 or Clang>=3.3."
+ fi
+}
diff --git a/media-libs/ffmpegsource/files/ffmpegsource-2.22-add-missing-extern-C.patch b/media-libs/ffmpegsource/files/ffmpegsource-2.22-add-missing-extern-C.patch
new file mode 100644
index 000000000000..9ef42d7113d6
--- /dev/null
+++ b/media-libs/ffmpegsource/files/ffmpegsource-2.22-add-missing-extern-C.patch
@@ -0,0 +1,27 @@
+commit 1dc922cdd0798d5522331f1c98657f494d18c6b9
+Author: Derek Buitenhuis <derek.buitenhuis@gmail.com>
+Date: Sun Dec 27 18:37:59 2015 -0500
+
+ track: Wrap C headers in extern "C" properly
+
+ This fixes av_rescale being undefiend during linking with some
+ GCC versions (e.g. 4.8.4 on Ubuntu 14.04).
+
+ Signed-off-by: Derek Buitenhuis <derek.buitenhuis@gmail.com>
+
+diff --git a/src/core/track.cpp b/src/core/track.cpp
+index 136bc21..23e57ad 100644
+--- a/src/core/track.cpp
++++ b/src/core/track.cpp
+@@ -25,9 +25,11 @@
+
+ #include <algorithm>
+
++extern "C" {
+ #include <libavutil/avutil.h>
+ #include <libavutil/common.h>
+ #include <libavutil/mathematics.h>
++}
+
+ namespace {
+ FrameInfo ReadFrame(ZipFile &stream, FrameInfo const& prev, const FFMS_TrackType TT) {
diff --git a/media-libs/ffmpegsource/files/ffmpegsource-2.22-fix-pixfmt-define.patch b/media-libs/ffmpegsource/files/ffmpegsource-2.22-fix-pixfmt-define.patch
new file mode 100644
index 000000000000..9815edc8fb43
--- /dev/null
+++ b/media-libs/ffmpegsource/files/ffmpegsource-2.22-fix-pixfmt-define.patch
@@ -0,0 +1,31 @@
+commit d4cf0fcdb355319e2f868d4e474a6b78b36848fd
+Author: Derek Buitenhuis <derek.buitenhuis@gmail.com>
+Date: Sun Dec 27 18:36:27 2015 -0500
+
+ ffmscompat: Use a separate version check for pixfmt flags
+
+ These changed during a separate version bump from the pixfmts themselves.
+
+ What a mess.
+
+ Signed-off-by: Derek Buitenhuis <derek.buitenhuis@gmail.com>
+
+diff --git a/include/ffmscompat.h b/include/ffmscompat.h
+index be99db8..eea9029 100644
+--- a/include/ffmscompat.h
++++ b/include/ffmscompat.h
+@@ -88,9 +88,13 @@ static void av_frame_free(AVFrame **frame) { av_freep(frame); }
+ # if VERSION_CHECK(LIBAVUTIL_VERSION_INT, <, 51, 42, 0, 51, 74, 100)
+ # define AVPixelFormat PixelFormat
+ # define FFMS_PIX_FMT(x) PIX_FMT_##x
+-# define FFMS_PIX_FMT_FLAG(x) PIX_FMT_##x
+ # else
+ # define FFMS_PIX_FMT(x) AV_PIX_FMT_##x
++# endif
++
++# if VERSION_CHECK(LIBAVUTIL_VERSION_INT, <, 52, 11, 0, 52, 32, 100)
++# define FFMS_PIX_FMT_FLAG(x) PIX_FMT_##x
++# else
+ # define FFMS_PIX_FMT_FLAG(x) AV_PIX_FMT_FLAG_##x
+ # endif
+
diff --git a/media-libs/ffmpegsource/files/ffmpegsource-2.22-include-missing-header.patch b/media-libs/ffmpegsource/files/ffmpegsource-2.22-include-missing-header.patch
new file mode 100644
index 000000000000..bae86ec49af3
--- /dev/null
+++ b/media-libs/ffmpegsource/files/ffmpegsource-2.22-include-missing-header.patch
@@ -0,0 +1,22 @@
+commit 848f7656e1e912352345f84b9499ab4483902d3b
+Author: Derek Buitenhuis <derek.buitenhuis@gmail.com>
+Date: Sun Dec 27 18:37:28 2015 -0500
+
+ track: Include missing header
+
+ This is requried for av_rescale.
+
+ Signed-off-by: Derek Buitenhuis <derek.buitenhuis@gmail.com>
+
+diff --git a/src/core/track.cpp b/src/core/track.cpp
+index 3300094..136bc21 100644
+--- a/src/core/track.cpp
++++ b/src/core/track.cpp
+@@ -27,6 +27,7 @@
+
+ #include <libavutil/avutil.h>
+ #include <libavutil/common.h>
++#include <libavutil/mathematics.h>
+
+ namespace {
+ FrameInfo ReadFrame(ZipFile &stream, FrameInfo const& prev, const FFMS_TrackType TT) {