summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-20 23:00:48 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-20 23:01:40 -0700
commitbcb09ed0c28ad2b012792bf37201b11f1cf72f73 (patch)
tree9c7ac86bfe124a512c99b6202c32e9d2e576b81e /media-libs/graphene
parentapp-crypt/jitterentropy-rngd: drop 1.2.5, 1.2.6 (diff)
downloadgentoo-bcb09ed0c28ad2b012792bf37201b11f1cf72f73.tar.gz
gentoo-bcb09ed0c28ad2b012792bf37201b11f1cf72f73.tar.bz2
gentoo-bcb09ed0c28ad2b012792bf37201b11f1cf72f73.zip
media-libs/graphene: Version bump to 1.10.8
Closes: https://bugs.gentoo.org/829434 Closes: https://github.com/gentoo/gentoo/pull/23371 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/graphene')
-rw-r--r--media-libs/graphene/Manifest1
-rw-r--r--media-libs/graphene/graphene-1.10.8.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/graphene/Manifest b/media-libs/graphene/Manifest
index 684a9cb2f00f..c03c56a88210 100644
--- a/media-libs/graphene/Manifest
+++ b/media-libs/graphene/Manifest
@@ -1 +1,2 @@
DIST graphene-1.10.6.tar.xz 333332 BLAKE2B d353efb22510b78c7360b748b7e83237309b88c170909e521d50e95618e907bd8b2424c3583a5db3ff2ca57954bf793646a69251bbb31caac55155c15981ed3a SHA512 075e8c712509655d0614258a7fd2943e67a9642334cdabdc15d2489a88c961e278f7464a513080cd287f5371c7ece8ceb7565d1718a8b71fea4a4977f82aeb72
+DIST graphene-1.10.8.tar.gz 178557 BLAKE2B 57739a9cfc246a38968fa8352e0c05ce9e32e50753e7d18b8b25ecebd1ea294cfad26168437e290209011b51085fad7d8a47852b99510a7402f9a7dd00ac17f0 SHA512 526b0c17049459b687ceb7f6c26c9d982535e4048e74a0b6282704f9811d3c2e7e0e6cfef166aa953306b6cf77add6677bc600ae0c66cc052dc04c3d0345bd68
diff --git a/media-libs/graphene/graphene-1.10.8.ebuild b/media-libs/graphene/graphene-1.10.8.ebuild
new file mode 100644
index 000000000000..7e96a061cac6
--- /dev/null
+++ b/media-libs/graphene/graphene-1.10.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit xdg-utils meson-multilib python-any-r1
+
+DESCRIPTION="A thin layer of types for graphic libraries"
+HOMEPAGE="https://ebassi.github.io/graphene/"
+SRC_URI="https://github.com/ebassi/graphene/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 doc +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.30.0:2[${MULTILIB_USEDEP}]
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+DEPEND="${RDEPEND}"
+# Python is only needed with USE=introspection or FEATURES=test, but not bothering with conditional python_setup, as meson uses it too anyway
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3
+ )
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ # TODO: Do we want G_DISABLE_ASSERT as buildtype=release would do upstream?
+ local emesonargs=(
+ $(meson_native_use_bool doc gtk_doc)
+ -Dgobject_types=true
+ $(meson_native_use_feature introspection)
+ -Dgcc_vector=true # if built-in support tests fail, it'll just not enable vector intrinsics; unfortunately this probably means disabled on clang too, due to it claiming to be <gcc-4.9
+ $(meson_use cpu_flags_x86_sse2 sse2)
+ $(meson_use cpu_flags_arm_neon arm_neon)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ )
+ meson_src_configure
+}