summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-12 22:06:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-12 22:27:32 +0200
commit083e1040cc287ec7d04f428d836f08f9c15c788c (patch)
treeb2a73b9e1cde1c061e23a2ff6dba77ec9fd819c9 /media-libs/libvisio
parentmedia-libs/libvisio: EAPI-7 bump (diff)
downloadgentoo-083e1040cc287ec7d04f428d836f08f9c15c788c.tar.gz
gentoo-083e1040cc287ec7d04f428d836f08f9c15c788c.tar.bz2
gentoo-083e1040cc287ec7d04f428d836f08f9c15c788c.zip
media-libs/libvisio: 0.1.7 version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/libvisio')
-rw-r--r--media-libs/libvisio/Manifest1
-rw-r--r--media-libs/libvisio/libvisio-0.1.7.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/media-libs/libvisio/Manifest b/media-libs/libvisio/Manifest
index e4d6b6ef69b2..ca606c2e2254 100644
--- a/media-libs/libvisio/Manifest
+++ b/media-libs/libvisio/Manifest
@@ -1 +1,2 @@
DIST libvisio-0.1.6.tar.xz 676396 BLAKE2B dbd96b64a3789e275a47fe59cd939620787937e31ee11b7af7977575c183ade233afdb952d4c2e362312ae400d23726cbd01e3ccb644c9a413abc84ddbe0f161 SHA512 58cee8cfe4205b2cad2f11dbe17882e57ebf0d10500116ca9d8d120e138f8eb0c65a5fea3bd7d2746bf8140377ee9deb34258597e028f9fdc8d21f270606cce1
+DIST libvisio-0.1.7.tar.xz 854296 BLAKE2B db5dd96d769c237bc2926d52a43c2496adca50b74133ea3c81df7ba5a61824891623eb33b4801b463b27f5c03946ea7ffcf827b98c95139c9659b0a1b0f7b604 SHA512 c26f67a09fa6a6d0bf6f3fff5590d5cf16983630d4f7cfcf86d9461baec58dbdf7989fd934be6db0639ca043c160aac2d008275afb9e047766bc878ac579a9ea
diff --git a/media-libs/libvisio/libvisio-0.1.7.ebuild b/media-libs/libvisio/libvisio-0.1.7.ebuild
new file mode 100644
index 000000000000..e4147a14c125
--- /dev/null
+++ b/media-libs/libvisio/libvisio-0.1.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libvisio.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libvisio/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Library parsing the file format of MS Visio documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+IUSE="doc static-libs test tools"
+
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ dev-libs/libxml2
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-util/gperf
+ sys-devel/libtool
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ default
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # bug 619688
+ append-cxxflags -std=c++14
+
+ local myeconfargs=(
+ $(use_with doc docs)
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}