summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/mash
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/mash')
-rw-r--r--media-libs/mash/Manifest1
-rw-r--r--media-libs/mash/mash-0.2.0-r1.ebuild48
-rw-r--r--media-libs/mash/metadata.xml9
3 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/mash/Manifest b/media-libs/mash/Manifest
new file mode 100644
index 000000000000..c193e2f15cef
--- /dev/null
+++ b/media-libs/mash/Manifest
@@ -0,0 +1 @@
+DIST mash-0.2.0.tar.xz 288844 SHA256 fd4089e2974a1a57f9ba209a0a47924ed157da9fc9a3d65f68a6b9fdca353ccc
diff --git a/media-libs/mash/mash-0.2.0-r1.ebuild b/media-libs/mash/mash-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..9a0b6e368599
--- /dev/null
+++ b/media-libs/mash/mash-0.2.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+# clutter.eclass does not support .xz tarballs
+inherit gnome2 versionator
+RV=($(get_version_components))
+SRC_URI="http://source.clutter-project.org/sources/${PN}/${RV[0]}.${RV[1]}/${P}.tar.xz"
+
+DESCRIPTION="A library for rendering 3D models with Clutter"
+HOMEPAGE="http://wiki.clutter-project.org/wiki/Mash"
+
+LICENSE="LGPL-2.1"
+SLOT="0.2"
+IUSE="doc examples +introspection"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+# Automagically detects x11-libs/mx, but only uses it for building examples.
+# Note: mash is using a bundled copy of rply because mash developers have
+# modified its API by adding extra arguments to various functions.
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=media-libs/clutter-1.5.10:1.0[introspection?]
+ virtual/opengl
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.14 )"
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS README"
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable introspection)"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins example/{*.c,*.ply}
+ fi
+}
diff --git a/media-libs/mash/metadata.xml b/media-libs/mash/metadata.xml
new file mode 100644
index 000000000000..b4df7ab52805
--- /dev/null
+++ b/media-libs/mash/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+</use>
+</pkgmetadata>