summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-01-25 09:39:09 -0800
committerMatt Turner <mattst88@gentoo.org>2017-01-25 09:39:09 -0800
commit6d40780deb810126154e868fa4c24c53e7163f04 (patch)
tree9c969a2fc2db71f715b35d85cf9269ad2b0e1da2 /media-libs/mesa
parentmedia-libs/mesa: Version bump to 17.0.0_rc2. (diff)
downloadgentoo-6d40780deb810126154e868fa4c24c53e7163f04.tar.gz
gentoo-6d40780deb810126154e868fa4c24c53e7163f04.tar.bz2
gentoo-6d40780deb810126154e868fa4c24c53e7163f04.zip
media-libs/mesa: Drop sha1 dependencies.
Upstream commit d1efa09d342bff removed all this nonsense by importing a single implementation of SHA1.
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-17.0.0_rc2.ebuild16
-rw-r--r--media-libs/mesa/mesa-9999.ebuild16
2 files changed, 6 insertions, 26 deletions
diff --git a/media-libs/mesa/mesa-17.0.0_rc2.ebuild b/media-libs/mesa/mesa-17.0.0_rc2.ebuild
index 34c1704f352b..7dae3be569c1 100644
--- a/media-libs/mesa/mesa-17.0.0_rc2.ebuild
+++ b/media-libs/mesa/mesa-17.0.0_rc2.ebuild
@@ -42,12 +42,11 @@ for card in ${VIDEO_CARDS}; do
done
IUSE="${IUSE_VIDEO_CARDS}
- bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gcrypt gles1 gles2
- libressl +llvm +nettle +nptl opencl osmesa pax_kernel openmax openssl pic
- selinux vaapi valgrind vdpau vulkan wayland xvmc xa kernel_FreeBSD"
+ bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +llvm
+ +nptl opencl osmesa pax_kernel openmax pic selinux vaapi valgrind vdpau
+ vulkan wayland xvmc xa kernel_FreeBSD"
REQUIRED_USE="
- || ( gcrypt libressl nettle openssl )
d3d9? ( dri3 gallium )
llvm? ( gallium )
opencl? ( gallium llvm )
@@ -103,14 +102,6 @@ RDEPEND="
) )
>=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
)
- nettle? ( dev-libs/nettle:=[${MULTILIB_USEDEP}] )
- !nettle? (
- gcrypt? ( dev-libs/libgcrypt:=[${MULTILIB_USEDEP}] )
- !gcrypt? (
- libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
- !libressl? ( dev-libs/openssl:=[${MULTILIB_USEDEP}] )
- )
- )
opencl? (
app-eselect/eselect-opencl
dev-libs/libclc
@@ -321,7 +312,6 @@ multilib_src_configure() {
--with-dri-drivers=${DRI_DRIVERS} \
--with-gallium-drivers=${GALLIUM_DRIVERS} \
--with-vulkan-drivers=${VULKAN_DRIVERS} \
- --with-sha1=$(usex nettle libnettle $(usex gcrypt libgcrypt libcrypto)) \
PYTHON2="${PYTHON}" \
${myconf}
}
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 34c1704f352b..7dae3be569c1 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -42,12 +42,11 @@ for card in ${VIDEO_CARDS}; do
done
IUSE="${IUSE_VIDEO_CARDS}
- bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gcrypt gles1 gles2
- libressl +llvm +nettle +nptl opencl osmesa pax_kernel openmax openssl pic
- selinux vaapi valgrind vdpau vulkan wayland xvmc xa kernel_FreeBSD"
+ bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +llvm
+ +nptl opencl osmesa pax_kernel openmax pic selinux vaapi valgrind vdpau
+ vulkan wayland xvmc xa kernel_FreeBSD"
REQUIRED_USE="
- || ( gcrypt libressl nettle openssl )
d3d9? ( dri3 gallium )
llvm? ( gallium )
opencl? ( gallium llvm )
@@ -103,14 +102,6 @@ RDEPEND="
) )
>=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
)
- nettle? ( dev-libs/nettle:=[${MULTILIB_USEDEP}] )
- !nettle? (
- gcrypt? ( dev-libs/libgcrypt:=[${MULTILIB_USEDEP}] )
- !gcrypt? (
- libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
- !libressl? ( dev-libs/openssl:=[${MULTILIB_USEDEP}] )
- )
- )
opencl? (
app-eselect/eselect-opencl
dev-libs/libclc
@@ -321,7 +312,6 @@ multilib_src_configure() {
--with-dri-drivers=${DRI_DRIVERS} \
--with-gallium-drivers=${GALLIUM_DRIVERS} \
--with-vulkan-drivers=${VULKAN_DRIVERS} \
- --with-sha1=$(usex nettle libnettle $(usex gcrypt libgcrypt libcrypto)) \
PYTHON2="${PYTHON}" \
${myconf}
}