summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-04-07 10:29:17 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-04-15 09:18:48 +0300
commitb0d92cef9f5c4b077879766cf32c85aa99419a98 (patch)
treea3717084f245245aa5d7b352b3f1e0f95c36c30f /media-libs/openexr
parentmedia-libs/ilmbase: bump to 2.5.8 (diff)
downloadgentoo-b0d92cef9f5c4b077879766cf32c85aa99419a98.tar.gz
gentoo-b0d92cef9f5c4b077879766cf32c85aa99419a98.tar.bz2
gentoo-b0d92cef9f5c4b077879766cf32c85aa99419a98.zip
media-libs/openexr: bump to 2.5.8
Closes: https://bugs.gentoo.org/837062 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/24939 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/openexr')
-rw-r--r--media-libs/openexr/Manifest1
-rw-r--r--media-libs/openexr/openexr-2.5.8.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/media-libs/openexr/Manifest b/media-libs/openexr/Manifest
index 39b88ea65170..5721a781b067 100644
--- a/media-libs/openexr/Manifest
+++ b/media-libs/openexr/Manifest
@@ -1,2 +1,3 @@
DIST openexr-2.5.7.tar.gz 27539574 BLAKE2B 58fd81be52e13d2815b6aa8cea6793359379f5ebf866fd45b31ce30cf5f72aa4699625e7cec51189d62fe76f53418c3e0938f9b827d54ad18342e7aa67c8a3d2 SHA512 e44edfa2dcfff2fe372ed2ba07b39a472e549025978de178eff26be641767d22d1a3b543fb7672d9b7b2e9f4c308667f785829ed6d9032a2b42f2ffa0163de40
+DIST openexr-2.5.8.tar.gz 27539605 BLAKE2B b54b72aa82c947fd7f252bf4d15b2727be2da7cdd257a9d96c6c2a3c892438ff850177549144e492617bfe5d260ddd14d21eac70a55f124784bbdf5f7077d1e9 SHA512 5b1ad99cfa639892292109a26c084868b3fe0acf572dd69750e951cec2127d63c78309241de92b0052f0abe50d86f2518e3185194121010db5f826d217e37f4f
DIST openexr-3.1.4.tar.gz 20323658 BLAKE2B d3726023f920fa719b1832d3be2df36a95cac8c67fdd4b23a7166398a282fa01d5c07065afd92f7b28f178c47843f82eb7a0f2b77742725b359c8f275d2ef1d0 SHA512 612ab3467f9ccf2779e1592361cb07459571122e10c0a0b3020430cfa34fa3b91ca1d63cc12a5f85d5b53b277b3f7a88862e6477f0f3566a4196b8245f6bfe12
diff --git a/media-libs/openexr/openexr-2.5.8.ebuild b/media-libs/openexr/openexr-2.5.8.ebuild
new file mode 100644
index 000000000000..50fc19f16ab7
--- /dev/null
+++ b/media-libs/openexr/openexr-2.5.8.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
+HOMEPAGE="https://www.openexr.com/"
+SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/OpenEXR"
+
+LICENSE="BSD"
+SLOT="0/25" # based on SONAME
+# -ppc -sparc because broken on big endian, bug #818424
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 -ppc ~ppc64 ~riscv -sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="cpu_flags_x86_avx doc examples static-libs utils test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ~media-libs/ilmbase-${PV}:=[static-libs?,${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( PATENTS README.md )
+
+src_prepare() {
+ # Fix path for testsuite
+ sed -i -e "s:/var/tmp/:${T}:" "${S}"/IlmImfTest/tmpDir.h || die "failed to set temp path for tests"
+
+ # disable failing tests on various arches
+ if use test; then
+ if use abi_x86_32; then
+ eapply "${FILESDIR}/${PN}-2.5.2-0001-IlmImfTest-main.cpp-disable-tests.patch"
+ fi
+
+ # Technically this doesn't disable anything, it just gives this test time to complete.
+ # Could probably be applied unconditionally but will leave this to the maintainers.
+ if use riscv; then
+ eapply "${FILESDIR}/${P}-0002-increase-IlmImfTest-timeout.patch"
+ fi
+
+ if use sparc; then
+ eapply "${FILESDIR}/${P}-0001-disable-testRgba-on-sparc.patch"
+ fi
+ fi
+
+ multilib_foreach_abi cmake_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DINSTALL_OPENEXR_DOCS=$(usex doc)
+ -DINSTALL_OPENEXR_EXAMPLES=$(usex examples)
+ -DOPENEXR_BUILD_BOTH_STATIC_SHARED=$(usex static-libs)
+ -DOPENEXR_BUILD_UTILS=$(usex utils)
+ -DOPENEXR_INSTALL_PKG_CONFIG=ON
+ -DOPENEXR_USE_CLANG_TIDY=OFF # don't look for clang-tidy
+ )
+
+ cmake_src_configure
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ DOCS+=( doc/*.pdf )
+ fi
+ einstalldocs
+
+ use examples && docompress -x /usr/share/doc/${PF}/examples
+}