summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/sg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/sg')
-rw-r--r--media-libs/sg/Manifest1
-rw-r--r--media-libs/sg/files/1.4-doc.patch20
-rw-r--r--media-libs/sg/files/1.4-opengl.patch98
-rw-r--r--media-libs/sg/metadata.xml8
-rw-r--r--media-libs/sg/sg-1.5.ebuild76
5 files changed, 203 insertions, 0 deletions
diff --git a/media-libs/sg/Manifest b/media-libs/sg/Manifest
new file mode 100644
index 000000000000..8fa4d97d7468
--- /dev/null
+++ b/media-libs/sg/Manifest
@@ -0,0 +1 @@
+DIST sg-1.5.tar.gz 2859299 SHA256 e7d499c33b87bd50c4b83b84e23a2aebd70ed01a3c9a7f4512d36216da487784 SHA512 0e1f931b51e7bdecedc1bb17275d87e7549abf3d4d9eff6daf74cbc97ad1bea94b256fe4accfe27bd0a67f0637bb0d3b363d748f57edd73e07e922d2ea6e24c0 WHIRLPOOL 2341df50012afb8e581cbca5913ee29b9db6e90788a5513ff9a14113c9eac462774fc97c7c13473b7639c6883ba225ac3f8fbffc384c77aa1394659b014ed413
diff --git a/media-libs/sg/files/1.4-doc.patch b/media-libs/sg/files/1.4-doc.patch
new file mode 100644
index 000000000000..cfc1b21b20cb
--- /dev/null
+++ b/media-libs/sg/files/1.4-doc.patch
@@ -0,0 +1,20 @@
+diff --git a/doc/doxygen/Makefile.am b/doc/doxygen/Makefile.am
+index 3ee562c..7f424e8 100644
+--- a/doc/doxygen/Makefile.am
++++ b/doc/doxygen/Makefile.am
+@@ -29,13 +29,11 @@
+ ## Author: Michael Holst
+ ## ###########################################################################
+
+-docdir = @prefix@/doc/sg
+-
+ doc_DATA = sg_doc
+
+ sg_doc:
+ $(doxygen_path) $(top_srcdir)/doc/doxygen/sg.dox
+
+ install-docDATA:
+- mkdir -p $(docdir)
+- cp -r ../api $(docdir)/
++ mkdir -p $(DESTDIR)/@docdir@
++ cp -r ../api $(DESTDIR)/@docdir@/
diff --git a/media-libs/sg/files/1.4-opengl.patch b/media-libs/sg/files/1.4-opengl.patch
new file mode 100644
index 000000000000..f6b32cf1d286
--- /dev/null
+++ b/media-libs/sg/files/1.4-opengl.patch
@@ -0,0 +1,98 @@
+diff --git a/configure.ac b/configure.ac
+index 68ff24a..a2cd6b5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -844,9 +844,6 @@ AC_OUTPUT([
+
+ src/base/Makefile
+
+- src/gl/Makefile
+- src/glu/Makefile
+- src/glw/Makefile
+ src/ogl/Makefile
+ src/vgl/Makefile
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index ad9562f..7d5173c 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -35,5 +35,5 @@
+ AUTOMAKE_OPTIONS = no-dependencies
+ SUFFIXES = .y .l .H .h .m .C .cc .c .f .java .o
+ always_built_SUBDIRS = ogl vgl
+-SUBDIRS = base @gl@ @glu@ @glw@ $(always_built_SUBDIRS) aaa_inc aaa_lib .
++SUBDIRS = base $(always_built_SUBDIRS) aaa_inc aaa_lib .
+
+diff --git a/src/aaa_inc/GL/Makefile.am b/src/aaa_inc/GL/Makefile.am
+index 10efb6b..0d5b8b7 100644
+--- a/src/aaa_inc/GL/Makefile.am
++++ b/src/aaa_inc/GL/Makefile.am
+@@ -37,27 +37,6 @@ SUFFIXES = .y .l .H .h .m .C .cc .c .f .java .o
+ always_built_SUBDIRS =
+ SUBDIRS = $(always_built_SUBDIRS) .
+
+-if BUILD_GL
+-GL_HEADS = gl.h glx.h osmesa.h wmesa.h xmesa.h
+-else
+-GL_HEADS =
+-endif
+-
+-if BUILD_GLU
+-GLU_HEADS = glu.h
+-else
+-GLU_HEADS =
+-endif
+-
+-if BUILD_GLW
+-GLW_HEADS = GLwDrawA.h
+-else
+-GLW_HEADS =
+-endif
+-
+-includedir = ${prefix}/include/GL
+-include_HEADERS = ${GL_HEADS} ${GLU_HEADS} ${GLW_HEADS}
+-
+ distclean-local: clean-local
+
+ clean-local:
+diff --git a/src/aaa_lib/Makefile.am b/src/aaa_lib/Makefile.am
+index bb93779..0512c45 100644
+--- a/src/aaa_lib/Makefile.am
++++ b/src/aaa_lib/Makefile.am
+@@ -41,32 +41,16 @@ BASE_LIBS = ../base/libbase.la
+ OGL_LIBS = ../ogl/libogl.la
+ VGL_LIBS = ../vgl/libvgl.la
+
+-GL_LIBS = ../gl/libGL.la
+-if BUILD_GL
+-LIBGL = libGL.la
+-else
+-LIBGL =
+-endif
++GL_LIBS = ${libdir}/libGL.la
+
+-GLU_LIBS = ../glu/libGLU.la
+-if BUILD_GLU
+-LIBGLU = libGLU.la
+-else
+-LIBGLU =
+-endif
++GLU_LIBS = ${libdir}/libGLU.la
+
+-GLW_LIBS = ../glw/libGLw.la
+-if BUILD_GLW
+-LIBGLW = libGLw.la
+-else
+-LIBGLW =
+-endif
++GLW_LIBS = ${libdir}/libGLw.la
+
+-libdir = ${prefix}/lib
+ lib_LTLIBRARIES = libsg.la ${LIBGL} ${LIBGLU} ${LIBGLW}
+
+ libsg_la_SOURCES =
+-libsg_la_LIBADD = ${BASE_LIBS} ${OGL_LIBS} ${VGL_LIBS}
++libsg_la_LIBADD = ${BASE_LIBS} ${OGL_LIBS} ${VGL_LIBS} -lGL -lGLU -lGLw -lXm -lmaloc -lXaw
+ libsg_la_LDFLAGS = -version-info ${FETK_VERSION}
+
+ libGL_la_SOURCES =
diff --git a/media-libs/sg/metadata.xml b/media-libs/sg/metadata.xml
new file mode 100644
index 000000000000..5ef07a39e7e1
--- /dev/null
+++ b/media-libs/sg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-libs/sg/sg-1.5.ebuild b/media-libs/sg/sg-1.5.ebuild
new file mode 100644
index 000000000000..80118fd41d3a
--- /dev/null
+++ b/media-libs/sg/sg-1.5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils multilib
+
+DESCRIPTION="Socket Graphics tool for displaying polygons"
+HOMEPAGE="http://fetk.org/codes/sg/index.html"
+SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/maloc
+ virtual/glu
+ x11-libs/libXaw
+ x11-libs/motif
+ || (
+ ( media-libs/mesa x11-libs/libGLw )
+ media-libs/opengl-apple
+ )"
+DEPEND="
+ ${RDEPEND}
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen
+ )"
+
+S="${WORKDIR}"/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/1.4-opengl.patch
+ "${FILESDIR}"/1.4-doc.patch
+ )
+
+src_prepare() {
+ rm src/{gl,glu,glw} -rf || die
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local sg_include
+ local sg_lib
+ local myeconfargs
+
+ sg_include="${EPREFIX}"/usr/include
+ sg_lib="${EPREFIX}"/usr/$(get_libdir)
+ export FETK_LIBRARY="${sg_lib}"
+ export FETK_MOTIF_LIBRARY="${sg_lib}"
+ export FETK_GL_LIBRARY="${sg_lib}"
+ export FETK_GLU_LIBRARY="${sg_lib}"
+ export FETK_GLW_LIBRARY="${sg_lib}"
+ export FETK_INCLUDE="${sg_include}"
+ export FETK_GLW_INCLUDE="${sg_include}"
+ export FETK_GLU_INCLUDE="${sg_include}"
+ export FETK_GL_INCLUDE="${sg_include}"/GL
+ export FETK_MOTIF_INCLUDE="${sg_include}"
+
+ use doc || myeconfargs+=( --with-doxygen= --with-dot= )
+
+ myeconfargs+=( --enable-glforce --enable-gluforce --enable-glwforce )
+
+ myeconfargs+=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-triplet
+ )
+ autotools-utils_src_configure
+}