summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-03-25 14:54:00 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-03-25 14:54:21 -0700
commit60a43bbe3ad871d4129056d0942a1d33edb92e94 (patch)
tree183ccbfdd63c13afb01c67d8e126d548d46bf077 /media-libs/tg_owt
parentmedia-libs/tg_owt: fix SSE2 build of latest snapshot (diff)
downloadgentoo-60a43bbe3ad871d4129056d0942a1d33edb92e94.tar.gz
gentoo-60a43bbe3ad871d4129056d0942a1d33edb92e94.tar.bz2
gentoo-60a43bbe3ad871d4129056d0942a1d33edb92e94.zip
media-libs/tg_owt: fix SSE2 build even better
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'media-libs/tg_owt')
-rw-r--r--media-libs/tg_owt/tg_owt-0_pre20210309.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/media-libs/tg_owt/tg_owt-0_pre20210309.ebuild b/media-libs/tg_owt/tg_owt-0_pre20210309.ebuild
index 0aa7644fe085..43dd4267f6c0 100644
--- a/media-libs/tg_owt/tg_owt-0_pre20210309.ebuild
+++ b/media-libs/tg_owt/tg_owt-0_pre20210309.ebuild
@@ -64,9 +64,11 @@ src_prepare() {
# See https://bugs.debian.org/982556
sed -i -e 's/#ifndef NO_MAIN_THREAD_WRAPPING/#if 0/' src/rtc_base/thread.cc || die
- # Causes forced inclusion of SSE2, so we strip it out on non-amd64 arches
+ # Causes forced inclusion of SSE2, so we strip it out on x86* arches
# https://github.com/desktop-app/tg_owt/pull/57
- use amd64 || sed -i '/modules\/desktop_capture/d' CMakeLists.txt || die
+ if ! use amd64 && ! use x86; then
+ sed -i '/modules\/desktop_capture/d' CMakeLists.txt || die
+ fi
cmake_src_prepare
}