summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-10-26 17:38:05 +0100
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-10-26 17:38:05 +0100
commit1bca70f53487f157d0df00deac7b46f133ee2cc6 (patch)
tree877353b0955e944829e61bfb56c374f778616fb4 /media-libs
parentapp-emulation/virtualbox-modules: Enabled verbose build. (diff)
downloadgentoo-1bca70f53487f157d0df00deac7b46f133ee2cc6.tar.gz
gentoo-1bca70f53487f157d0df00deac7b46f133ee2cc6.tar.bz2
gentoo-1bca70f53487f157d0df00deac7b46f133ee2cc6.zip
media-libs/raspberrypi-userland: new snapshot
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/raspberrypi-userland/Manifest1
-rw-r--r--media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20150921.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/raspberrypi-userland/Manifest b/media-libs/raspberrypi-userland/Manifest
index 27838fcb95bb..730152c7ce1d 100644
--- a/media-libs/raspberrypi-userland/Manifest
+++ b/media-libs/raspberrypi-userland/Manifest
@@ -1,3 +1,4 @@
DIST raspberrypi-userland-0_pre20130705.tar.xz 31966608 SHA256 6307cc9d6103cd8afddf1b94ab44c4071f80884ec85d8e5aadd0f2f3d631c713 SHA512 d83de618e8fa6d49bd0b5b265706c7b290fa5800ac9a674dbf3d34222ab25e92c99877d61c4f706292666bf130ee0118ad54f35c8379a281f8ee90ce76a89651 WHIRLPOOL 8077d99e7a970f37bb4961ac928f9860b47be8aee83bff00eb4c44ee511aa322c532c9ff52528aece0897247ed8472aa70c147794aafe546ece8f8a08c5eb208
DIST raspberrypi-userland-0_pre20140117.tar.xz 31998784 SHA256 2999d711465ddbc6b70d429a0253b8a9c1f838351a96f2b25cc86109a879005f SHA512 5c3dfebdcb36a2a17da94cafcc92067b24b454d5694b0bd216dd0d6752c4f505840880094c22125ab5da60f7b53b9114e8d04359a223e9e00be967cb8585e42e WHIRLPOOL 5179758c2be4b45f640eb8759554e19ea4fc8c83e63b0d4396ae84e67ae82e97824bf12f0766df5a70e2ca5b80e90be80e5c9b2eaa968752829765463d3f6d0d
DIST raspberrypi-userland-0_pre20140830.tar.xz 32066536 SHA256 f9a06d2ca7d41cdc700b83eeb7c3e06d3ea6bd3fd187880a563144a6bf6ee901 SHA512 775005177e760fff611d7ce7e4beb466ea111dfc4652b97593d1061b97b1ded32979f8666a0aada6338791abab988883bbfd902f267eba5734e8aa932ebcf487 WHIRLPOOL 3066272a88b868ef20f27614f6f680aa6eb8a43cd2e281a7a930b99be341b037fa843a1c36bfdc6be619544e5b4b8751e5ab58c853b1baff44894b39284bfa55
+DIST raspberrypi-userland-0_pre20150921.tar.xz 32395092 SHA256 771bf96111d40c3b86cf2590f22d02306e5f56668f6ee11ace389c719bfccb2b SHA512 0aad096f5c6d54ef1d494708e80f8fb921e30e0d93ced79b4e939afffa8e824e35347595d6f925d1d7ee86917e72fa0b160ad56c8a4df7711d5e87b5cc399be1 WHIRLPOOL 2204dd8f8acf79c3d8baab770e133d18596f00fbf714e9ab46bf4a5ae1a1c0cf9edcbf763bf7fc0403126bb0ca9de7f422a3427dd429d849df6aee1be08b4b6a
diff --git a/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20150921.ebuild b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20150921.ebuild
new file mode 100644
index 000000000000..e18e32c0d016
--- /dev/null
+++ b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20150921.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/userland"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/${PN/-//}.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+# TODO:
+# * port vcfiled init script
+# * stuff is still installed to hardcoded /opt/vc location, investigate whether
+# anything else depends on it being there
+# * live ebuild
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]]; then
+ git-2_src_unpack
+ else
+ default
+ mv userland-*/ ${P}/ || die
+ fi
+}
+
+src_prepare() {
+ # init script for Debian, not useful on Gentoo
+ sed -i "/DESTINATION \/etc\/init.d/,+2d" interface/vmcs_host/linux/vcfiled/CMakeLists.txt || die
+}
+
+src_configure() {
+ # toolchain file not needed, but build fails if it is not specified
+ local mycmakeargs="-DCMAKE_TOOLCHAIN_FILE=/dev/null"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doenvd "${FILESDIR}"/04${PN}
+
+ # enable dynamic switching of the GL implementation
+ dodir /usr/lib/opengl
+ dosym ../../../opt/vc /usr/lib/opengl/${PN}
+
+ # tell eselect opengl that we do not have libGL
+ touch "${ED}"/opt/vc/.gles-only
+}