summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2024-08-30 21:40:46 +0200
committerYixun Lan <dlan@gentoo.org>2024-09-04 02:30:52 +0000
commit1cb4cb75ba262928bd283747912cc68868b2f855 (patch)
tree89cfe4d4a23ef275504b9332a9a764cd8ae3b434 /media-libs
parentmedia-libs/tg_owt: Bump to 0_pre20240804 (diff)
downloadgentoo-1cb4cb75ba262928bd283747912cc68868b2f855.tar.gz
gentoo-1cb4cb75ba262928bd283747912cc68868b2f855.tar.bz2
gentoo-1cb4cb75ba262928bd283747912cc68868b2f855.zip
media-libs/libtgvoip: Bump to 2.4.4_p20240706
Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libtgvoip/Manifest1
-rw-r--r--media-libs/libtgvoip/libtgvoip-2.4.4_p20240706.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-libs/libtgvoip/Manifest b/media-libs/libtgvoip/Manifest
index 578e0da87ddb..9187fef08c5a 100644
--- a/media-libs/libtgvoip/Manifest
+++ b/media-libs/libtgvoip/Manifest
@@ -1 +1,2 @@
DIST libtgvoip-2.4.4_p20221208.tar.gz 1098020 BLAKE2B 6f1eae38e4396ca3b88ab4337176a6076d5f9008b2a865cd286265a9b73d83d44c2cc6828b65dcb580a897a19badeab502395e2128a15c276ae796ac1ab0da68 SHA512 62243629890b1c13f1dbbffae4f82964a0fe23d2071852730674ccbef31126c6e205cfa526f07ba1549ef8eae31e371fb4335ce5f95fd649560bee2b3b530e64
+DIST libtgvoip-2.4.4_p20240706.tar.gz 1089879 BLAKE2B 0b0b83d4c43b18ab6af0cfd2795887180c4cb89d2b4ca22680a472e61c4908a4d2634fcb14677702bc9dc10e0df8d61029e0d361aa53303940cfbec36516afee SHA512 80d09c3e2a02461a2e71855ef086d453c4a95829c8183c7768f390bef82ab2124a3059931a043704e010d5e9ca512ee3001eb054dd3903f84ab51970e52e2ef4
diff --git a/media-libs/libtgvoip/libtgvoip-2.4.4_p20240706.ebuild b/media-libs/libtgvoip/libtgvoip-2.4.4_p20240706.ebuild
new file mode 100644
index 000000000000..3032ed6833b6
--- /dev/null
+++ b/media-libs/libtgvoip/libtgvoip-2.4.4_p20240706.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic autotools
+
+DESCRIPTION="VoIP library for Telegram clients"
+HOMEPAGE="https://github.com/telegramdesktop/libtgvoip"
+
+LIBTGVOIP_COMMIT="2d2592860478e60d972b96e67ee034b8a71bb57a"
+SRC_URI="https://github.com/telegramdesktop/libtgvoip/archive/${LIBTGVOIP_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${LIBTGVOIP_COMMIT}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv"
+IUSE="+dsp +alsa pulseaudio"
+
+DEPEND="
+ dev-libs/openssl:=
+ media-libs/opus
+ alsa? ( media-libs/alsa-lib )
+ dsp? ( media-libs/tg_owt:= )
+ pulseaudio? ( media-libs/libpulse )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+REQUIRED_USE="
+ || ( alsa pulseaudio )
+"
+
+src_prepare() {
+ # Will be controlled by us
+ sed -i -e '/^CFLAGS += -DTGVOIP_NO_DSP/d' Makefile.am || die
+ # https://bugs.gentoo.org/717210
+ echo 'libtgvoip_la_LIBTOOLFLAGS = --tag=CXX' >> Makefile.am || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Not using the CMake build despite being the preferred one, because
+ # it's lacking relevant configure options.
+ local myconf=(
+ --disable-dsp # WebRTC is linked from tg_owt
+ $(use_with alsa)
+ $(use_with pulseaudio pulse)
+ )
+ if use dsp; then
+ append-cppflags "-I${ESYSROOT}/usr/include/tg_owt"
+ append-cppflags "-I${ESYSROOT}/usr/include/tg_owt/third_party/abseil-cpp"
+ append-libs '-ltg_owt'
+ else
+ append-cppflags '-DTGVOIP_NO_DSP'
+ fi
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}