summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-06-16 18:42:58 +0200
committerDavid Seifert <soap@gentoo.org>2019-06-16 18:42:58 +0200
commit6168b5a550af1b3df0f11421cc460a56f4c51d00 (patch)
tree5c79422792453627fe93ee01f791d0c07709e110 /media-libs
parentmedia-sound/hydrogen-9999: removed gnuinstalldirs patch (diff)
downloadgentoo-6168b5a550af1b3df0f11421cc460a56f4c51d00.tar.gz
gentoo-6168b5a550af1b3df0f11421cc460a56f4c51d00.tar.bz2
gentoo-6168b5a550af1b3df0f11421cc460a56f4c51d00.zip
media-libs/libilbc: Update live ebuild
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libilbc/libilbc-9999.ebuild29
1 files changed, 20 insertions, 9 deletions
diff --git a/media-libs/libilbc/libilbc-9999.ebuild b/media-libs/libilbc/libilbc-9999.ebuild
index a7ac81e5c6d4..1d00bd81c2f7 100644
--- a/media-libs/libilbc/libilbc-9999.ebuild
+++ b/media-libs/libilbc/libilbc-9999.ebuild
@@ -1,19 +1,18 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-if [[ ${PV} == 9999 ]] ; then
- SCM="autotools git-2"
+inherit multilib-minimal
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
EGIT_REPO_URI="https://github.com/TimothyGu/${PN}"
- SRC_URI=""
else
SRC_URI="https://github.com/TimothyGu/${PN}/releases/download/v${PV}/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
fi
-inherit eutils multilib ${SCM} autotools-multilib
-
DESCRIPTION="Packaged version of iLBC codec from the WebRTC project"
HOMEPAGE="https://github.com/TimothyGu/libilbc"
@@ -22,6 +21,18 @@ SLOT="0"
IUSE="static-libs"
src_prepare() {
+ default
[[ ${PV} == *9999 ]] && eautoreconf
- autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
}