summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <darkdefende@gmail.com>2023-04-03 18:25:46 +0200
committerSam James <sam@gentoo.org>2023-04-16 03:45:59 +0100
commitc313bd382752056f998eb9f456a08107060dbeb5 (patch)
treec55291a059ef1eb527077fd51aaef6fc228accb2 /media-libs
parentmedia-gfx/blender: OpenImageIO is now a hard dependecy in newer Blender versions (diff)
downloadgentoo-c313bd382752056f998eb9f456a08107060dbeb5.tar.gz
gentoo-c313bd382752056f998eb9f456a08107060dbeb5.tar.bz2
gentoo-c313bd382752056f998eb9f456a08107060dbeb5.zip
media-libs/openpgl: New package
OpenPGL is a pathguiding library developed by Intel. This can be used in raytracing engines to guide rays in clever ways to reduce the overall noise of the picture in difficult lighting situations. Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/openpgl/Manifest1
-rw-r--r--media-libs/openpgl/metadata.xml24
-rw-r--r--media-libs/openpgl/openpgl-0.5.0.ebuild36
3 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/openpgl/Manifest b/media-libs/openpgl/Manifest
new file mode 100644
index 000000000000..6b2d7becd00d
--- /dev/null
+++ b/media-libs/openpgl/Manifest
@@ -0,0 +1 @@
+DIST openpgl-0.5.0.tar.gz 10767365 BLAKE2B 051b26c17300506dd20989ba9dc1aa83b0baf77c5f24650c74518ae56081b5a0ecca88c13d5d79a71cb0b6fa4a5b4841ee03e5223ec91ab16bb5655f2e52a9d7 SHA512 9b992ffa17ad6f9fcde48add5d9cc1e58be2daacd40478fb1babe0741a6c7a64f12f36c9c1f7d5ec6f79cdd847c082d39e03e58cfd9af1a903adca56f1ac19e1
diff --git a/media-libs/openpgl/metadata.xml b/media-libs/openpgl/metadata.xml
new file mode 100644
index 000000000000..362878695f7a
--- /dev/null
+++ b/media-libs/openpgl/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>darkdefende@gmail.com</email>
+ <name>Sebastian Parborg</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ The Intel® Open Path Guiding Library (Intel® Open PGL) implements a set of
+ representations and training algorithms needed to integrate path guiding
+ into a renderer. Open PGL offers implementations of current state-of-the-art
+ path guiding methods, which increase the sampling quality and, therefore,
+ the efficiency of a renderer. The goal of Open PGL is to provide
+ implementations that are well tested and robust enough to be used in a
+ production environment.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">OpenPathGuidingLibrary/openpgl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/openpgl/openpgl-0.5.0.ebuild b/media-libs/openpgl/openpgl-0.5.0.ebuild
new file mode 100644
index 000000000000..9c6a928d4802
--- /dev/null
+++ b/media-libs/openpgl/openpgl-0.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Intel Open Path Guiding Library"
+HOMEPAGE="https://github.com/OpenPathGuidingLibrary/openpgl"
+SRC_URI="https://github.com/OpenPathGuidingLibrary/openpgl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+X86_CPU_FLAGS=( sse4_2 avx2 avx512dq )
+CPU_FLAGS=( ${X86_CPU_FLAGS[@]/#/cpu_flags_x86_} )
+IUSE="${CPU_FLAGS[@]%:*} debug"
+SLOT="0"
+
+RDEPEND="
+ media-libs/embree
+ dev-cpp/tbb:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOPENPGL_ISA_AVX2=$(usex cpu_flags_x86_avx2)
+ -DOPENPGL_ISA_AVX512=$(usex cpu_flags_x86_avx512dq)
+ -DOPENPGL_ISA_SSE4=$(usex cpu_flags_x86_sse4_2)
+ )
+
+ # Disable asserts
+ append-cppflags $(usex debug '' '-DNDEBUG')
+
+ cmake_src_configure
+}