summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-02-13 20:06:20 +0200
committerMart Raudsepp <leio@gentoo.org>2021-02-13 21:48:49 +0200
commit580f782151a9d0179c43d014b08dbbd33e724fed (patch)
tree722db68bea036f1efda5405224a7135141c56eaa /media-plugins/gst-plugins-webrtc
parentmedia-plugins/gst-plugins-voamrwbenc: bump to 1.16.3 (diff)
downloadgentoo-580f782151a9d0179c43d014b08dbbd33e724fed.tar.gz
gentoo-580f782151a9d0179c43d014b08dbbd33e724fed.tar.bz2
gentoo-580f782151a9d0179c43d014b08dbbd33e724fed.zip
media-plugins/gst-plugins-webrtc: bump to 1.16.3
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-webrtc')
-rw-r--r--media-plugins/gst-plugins-webrtc/Manifest1
-rw-r--r--media-plugins/gst-plugins-webrtc/gst-plugins-webrtc-1.16.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-webrtc/Manifest b/media-plugins/gst-plugins-webrtc/Manifest
index fe307b250fae..c1da36dd35df 100644
--- a/media-plugins/gst-plugins-webrtc/Manifest
+++ b/media-plugins/gst-plugins-webrtc/Manifest
@@ -1 +1,2 @@
DIST gst-plugins-bad-1.16.2.tar.xz 4887812 BLAKE2B edf10aeb365d9a7cf4b5172af29b46cff4c7a49a3e4dde881469f5738b5a525eb51a6f70bb1dd6f680e4e48977d65769ac8e8f41d914b7ce7719b9fa260a7bd4 SHA512 aeaf3388156fe7317e193a3f940d391a6d8a1187f93e6925cee4cb02c4e78d9b456c22c27c318f0f9b2212ca68887c5cdcc256adaf068bfab8ec5c091a1e8805
+DIST gst-plugins-bad-1.16.3.tar.xz 4900188 BLAKE2B 7d8280a434adb1cb65b065dcdabdb37aad000802c011bb27779c109978d8b75aa4e2fa47043dde95464bb0c34a0d7466dc1f6216f29f0f4911f7a6fe1fb04b25 SHA512 378d8813ba2fd61ea2cab512d5c1fa81e0a4ac4f4ca756547d9b8742e56024c1bc5d6cd332798de66ecfe2b69485c860e181a6c2090398b0e2ad8c4b3fe95d04
diff --git a/media-plugins/gst-plugins-webrtc/gst-plugins-webrtc-1.16.3.ebuild b/media-plugins/gst-plugins-webrtc/gst-plugins-webrtc-1.16.3.ebuild
new file mode 100644
index 000000000000..794b2b954bad
--- /dev/null
+++ b/media-plugins/gst-plugins-webrtc/gst-plugins-webrtc-1.16.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="WebRTC plugins for GStreamer"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:1.0[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-bad-${PV}:1.0[${MULTILIB_USEDEP}]
+ >=media-libs/webrtc-audio-processing-0.2[${MULTILIB_USEDEP}]
+ <media-libs/webrtc-audio-processing-0.4
+ >=net-libs/libnice-0.1.14[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_BUILD="webrtc webrtcdsp"
+GST_PLUGINS_BUILD_DIR="webrtc webrtcdsp"
+
+src_prepare() {
+ default
+ gstreamer_system_link gst-libs/gst/webrtc:gstreamer-webrtc
+ gstreamer_system_link gst-libs/gst/sctp:gstreamer-sctp
+ gstreamer_system_link gst-libs/gst/audio:gstreamer-bad-audio
+}