summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-alcd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-alcd')
-rw-r--r--media-plugins/vdr-alcd/Manifest1
-rw-r--r--media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-gcc-4.4.diff22
-rw-r--r--media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-makefile-cleanup.diff44
-rw-r--r--media-plugins/vdr-alcd/metadata.xml19
-rw-r--r--media-plugins/vdr-alcd/vdr-alcd-1.5.1.ebuild22
5 files changed, 108 insertions, 0 deletions
diff --git a/media-plugins/vdr-alcd/Manifest b/media-plugins/vdr-alcd/Manifest
new file mode 100644
index 000000000000..7d94fa9be22e
--- /dev/null
+++ b/media-plugins/vdr-alcd/Manifest
@@ -0,0 +1 @@
+DIST vdr-alcd-1.5.1.tgz 40104 SHA256 9643d9f1214c33c8e5743e715b0e8c9a476e2df6f41f077bcf297ab03a33fe49
diff --git a/media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-gcc-4.4.diff b/media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-gcc-4.4.diff
new file mode 100644
index 000000000000..a4465220534a
--- /dev/null
+++ b/media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-gcc-4.4.diff
@@ -0,0 +1,22 @@
+Index: alcd-1.5.1/thread.c
+===================================================================
+--- alcd-1.5.1.orig/thread.c
++++ alcd-1.5.1/thread.c
+@@ -104,7 +104,7 @@ void cLCD::SetText( const char *szText )
+ // only proceed, if valid data
+ if( szText != NULL && strlen( szText ) > 0 ) {
+ // set channel name
+- char *delim = strchr( szText, '|' );
++ const char *delim = strchr( szText, '|' );
+ if( delim ) {
+ char buffer[ BUFSIZE ];
+ int sLen = ( delim - szText ) >= BUFSIZE ? BUFSIZE : ( delim - szText );
+@@ -420,7 +420,7 @@ void cLCD::Replaying( const cControl *co
+ if( szFileName[i] == ')' )
+ strncpy( (char *)szReplayMode, szFileName + 8, i - 8 );
+ }
+- char *p = strstr( szFileName + i, " : " );
++ const char *p = strstr( szFileName + i, " : " );
+ if( p )
+ strncpy( szTemp, p + 3, sizeof(szTemp ));
+ else
diff --git a/media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-makefile-cleanup.diff b/media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-makefile-cleanup.diff
new file mode 100644
index 000000000000..ea1488e40b0f
--- /dev/null
+++ b/media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-makefile-cleanup.diff
@@ -0,0 +1,44 @@
+Index: alcd-1.5.1/Makefile
+===================================================================
+--- alcd-1.5.1.orig/Makefile
++++ alcd-1.5.1/Makefile
+@@ -23,8 +23,8 @@ VDRINC = $(VDRDIR)/include
+ LIBDIR = ../../lib
+ TMPDIR = /tmp
+
+-CXX = g++
+-CXXFLAGS = -O2 -Wall -Woverloaded-virtual -D_GNU_SOURCE
++CXX ?= g++
++CXXFLAGS ?= -fPIC -O2 -Wall -Woverloaded-virtual
+
+ -include $(VDRDIR)/Make.config
+
+@@ -41,6 +41,8 @@ PACKAGE = vdr-$(ARCHIVE)
+
+ INCLUDES = -I$(VDRDIR)/include
+
++DEFINES += -D_GNU_SOURCE
++
+ ### Allow user defined options to overwrite defaults:
+
+ DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+@@ -53,6 +55,10 @@ endif
+
+ OBJS = $(PLUGIN).o lcd.o thread.o setup.o
+
++### The main target:
++
++all: libvdr-$(PLUGIN).so i18n
++
+ ### Target directory for afp-tool binary
+
+ PREFIX = /usr
+@@ -100,8 +106,6 @@ i18n: $(I18Nmsgs)
+
+ ### Targets:
+
+-all: libvdr-$(PLUGIN).so i18n
+-
+ libvdr-$(PLUGIN).so: $(OBJS)
+ $(CXX) $(CXXFLAGS) -shared $(OBJS) -o $@
+ @cp $@ $(LIBDIR)/$@.$(APIVERSION)
diff --git a/media-plugins/vdr-alcd/metadata.xml b/media-plugins/vdr-alcd/metadata.xml
new file mode 100644
index 000000000000..b3d0dc1c6eae
--- /dev/null
+++ b/media-plugins/vdr-alcd/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+</maintainer>
+<maintainer>
+ <email>vdr@helmutauer.de</email>
+ <name>Helmut Auer</name>
+ <description>Upstream maintainer</description>
+</maintainer>
+<longdescription lang="en">
+VDR plugin: Control the LCD of the Siemens Activy 300
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-alcd/vdr-alcd-1.5.1.ebuild b/media-plugins/vdr-alcd/vdr-alcd-1.5.1.ebuild
new file mode 100644
index 000000000000..1c14bc581548
--- /dev/null
+++ b/media-plugins/vdr-alcd/vdr-alcd-1.5.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: Control Activy 300 LCD"
+HOMEPAGE="http://www.htpc-forum.de"
+SRC_URI="http://www.htpc-forum.de/download/${P}.tgz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.6.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=("${FILESDIR}/${P}-makefile-cleanup.diff"
+ "${FILESDIR}/${P}-gcc-4.4.diff")